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Introduction

Thank you for your purchase and welcome to Max-10, the
sophisticated, exceptionally user~friendly word processor for the
Tandy Color Computer 3. High quality desktop publishing on your
C_olor Computer is finally possible. Max-10 follows the lead of its
sister product, CoCo Max 3 by offering such features as pull-down
menus, icons, dialog boxes and muitiple columns. It is so easy to use
ghat you could probably even start writing letters and reports almost
immediately without reading this manual. However, for the most
painless introduction, we strongly suggest you read it.

There are many good word processors for the Color Computer, so

what, you may ask, makes Max-10 different ?

> Max-10 is the only true WYSIWYG (What You See Is What You Get)
word processor for the Color Computer.

> Pages can be printed in columns making it easy to create
newsletters, club builletins and the like.

> Manipulation of multiple fonts and the ability to incorporate pictures
into the text make it suited for desktop publishing applications.

> Text appears on the screen as it will be printed. Subscripts and
sypt)e:rscripts as well as muitiple font sizes and pictures are easily
visible,

*> If you make a change and then decide against it, the Undo function
will completely cancel the effect of the change.

> Max~-10 is so easy to use it is almost completely intuitive.

Note

Max~10 requires: a CoCo 3; at least one disk drive; a joystick or
mouse; a video or RGB monitor or a TV; and a Hi~Res Joystick
Interface.

The new low cost Max-10 does not include the Hi-Res
Joystick Interface, as most users already have one. The "High
Res Joystick Interface” is available at Radio Shack (Cat # 26—~

3023). Colorware's CoCo Max Ill Hi-Res Interface can also be
used.
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Before you get started

We tried to make Max-10 as smooth and easy as possible. For this
reason, we do not copy—protect the Max~-10 disk. We did this because
you, the user requested it. Now that we have responded to our
customers' requests, we request something of you. Please do not
ilegally duplicate this and other software products. Although it is not a
violation of federal copyright laws to make a back-up copy for your
own use, making or distributing additional copies for any reason
is against the law. Even making copies for other computers which
are in the same room and are being used at the same time is illegal.
Many people work hard to produce a program of this complexity. By
not illegally giving away copies of it, you are helping to protect their
right to be compensated for their efforts through legitimate sales.
Without them we could not continue to develop even better and more
innovative softwa. e for the Color Computer.

Making BACKUP disks
Max—-10 is compatible with any Radio Shack (RSDOS) operating
system. It will not support hard drive systems.

Here are step—by-step instructions for the beginner.

Put a blank disk in drive 0 and type DSKINI 0.

If there is a write protect tab (litttle black or silver tab) on your Max-10
disk, do not remove it.

Disk BASIC will usually copy a disk without errors, but if you want to
be absolutely sure that your master disk is copied exactly, type
VERIFY ON. However, this will slow the backup procedure
considerably.

If you have two drives:

— Put the Max—10 disk in drive zero and put the blank disk you just
initialized into drive 1

- Type BACKUPOTO 1

If you have one drive:

— Put the Max~10 disk in the drive.

- Type BACKUP 0 TO 0 and follow the prompts on the screen. (Note
that the source disk is the Max-10 disk and the destination disk is
the copy you are making.) .

Put a write protect tab on the Backup disk and store the original disk

in a safe place with an extra backup, just in case.

From now on, whenever we refer to the Max—10 disk, we mean the

backup. The original should never be used unless the Backup is

damaged and you need to make another Backup disk.

@LORWARE
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Configuring Max-10

This step is necessary in order to customize Max—10 to your particular
menitor, Hi~Res interface and printer. If you do not want to print right
away and have a CoCo Max lil (one plug) Hi-Res interface, this may
be done later.

In any case, never configure the original Max-10 disk.

The configuration procedure is simple:

- Place a Backup copy of Max—10 in drive zero.

— Type RUN "CONFIG" and press ENTER

- Follow the instructions that appear on the screen.

Differences between 128k and 512k Color Computers

Max—-10 works equally well on either Color Computer. There are only
two differences between the 512k and 128k machines.

1) The Clipboard and extra printer fonts are stored in memory on the
512k CoCo while the 128k machine usually stores that data on disk.

2) The increased memory of the 512k computer means that a
document which is twice as large as the maximum allowed on the
128k CoCo may be edited.

3) If you have the dictionary option, the spelicheck utility is loaded
immediately into memory for faster access.

Starting Max—10

Plug in your Hi-Res interface and joystick. Note that the interface is
connected to the right joystick port. Put the backup disk in drive 0 and
type RUN "MAX"

A presentation screen (created using CoCo Max 3 and Max—10) will
be displayed for a few seconds while Max—-10 is loaded into memory.
When loading is completed, your screen should look like this:

File Edit Search+ layout Fonil Style

insertion point marker

k pointer

Typical Max—! 0 Screen
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Max—-10: A Tutorial

Manual Overview

This manual is organized in three sections: the first is a hands on
tutorial; the second is called Working with Max-10. It goes into more
detail and discusses the more advanced features of Max—10, including
its graphic capabilities and desktop publishing features. Next is a
reference guide that more systematically describes all the functions
in each of the pull-down menus. At the end of the manual you will find
a glossary of the many terms used in this manual and an index to
help you find information quickly. If we can judge by the tremendous
success of CoCo Max, our graphic editor, Max—10 will become a de
facto standard, and many advanced users might want o have access
to the disk file. A technical reference manual is available for $5.00 + $4
shipping and handling.

The Screen and Keyboard

In Max-10, a document is what you create when you put anything in
a document window, whether it's one word, a shopping list, a letter, or
a picture transiated from a graphics editor.

The Screen (refer to picture on the previous page)

A Max—10 screen consists of a menu bar, a scroll bar and the
window.

Inside the window are the ruler and a blinking vertical bar. The ruler
has adjustable settings for margins, tabs, line spacing and text
alignment. The vertical bar is used to mark the insertion point which
is the point where text appears as you type. This bar is moved around
the screen with the mouse. The arrow keys may be used with the
CTRL and ALT keys to move about the document also. Holding down
CTRL and pressing any arrow key will move left,right, up or down one
line or character. If the ALT key is depressed while hitting an up or
down arrow, you may scroll through the document one screenful at a
time. At the boitom of the window are the page number and column
indicators. The page number indicator shows what page currently
occupies the top of the window. The function of the column indicator
will be explained later.

The scroll bar is used to move through the document in order that
you may see its different parts. During lengthy operations, a clock icon
will flash at the bottom of the scroll bar to let you know that the
computer is busy.

The menu bar contains the titles of menus from which you choose
commands.
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The Keyboard

In this manual. we will often make references to certain keys or terms.
Here are some of the most common. You may also consult the
glossary at the end of the manual for more information.

Backspace — The Color Computer has no dedicated Backspace key,
so the left arrow key is used to perform this function.

Line Feed - A line feed is an invisible character that ends a line and
causes the next character you type to appear on the next line. It is
similar to the carriage return on a typewriter. It is generated when you
hit the ENTER key.

Tab - The Color Computer has no dedicated Tab key, so the right
arrow key is used instead.

Other Keys on the Keyboard

Shift-Zero: Unlike most typewriters and computer keyboards, the
Color Computer does not have a "Caps Lock™ key. Instead, to switch
between "ALL CAPITALS" mode and "Upper/Lowercase" mode, you
will be using the combination: SHIFT-0 (hold down the SHIFT key and
press zero). This is convenient when you want to capitalize an entire
word or sentence. To revert to upper/lowercase, press SHIFT-0 again.
The Control (CTRL) key, next to the “A” key, used with other keys is
a quick way of accessing menu functions. The appropriate control key
is noted next to certain menu choices. A list is also included at the end
of this manual. Using the control keys is an alternate way of making
menu choices instead of using the mouse.

The ALT key, like the CTRL key, is used in connection with other keys
to provide characters such as }, { and _ which are not found on the
Color Computer keyboard.

Note: The ALT and CTRL keys must be held down while the
appropriate letter key is pressed.

Type ahead is a term used to describe being able to type "ahead” of
the computer. When this occurs, the computer will lag behind in
printing the letters you typed. This is not usually a problem as the
letters you type are stored as fast as you can type them, but with
some text fonts (alternate character styles), the display may require
more time to “draw” the letters on the screen. Max—10 is capable of
accepting text at a rate of approximately 70 words per minute and if
you are a very fast typist, you may see the computer still writing to the
screen a second or so after you stop typing. Pressing the BREAK key
will immediately stop type ahead.

Key Click is a feature provided by Max—10 for touch typists. When
activated, the sound of clicking keys can be heard when the keys are
struck. Max—10 initializes with key click on, to turn it off, click on the
Key Click entry in the Search+ menu. Turning key click off also
enables Max~—10 to accept text at 100 words per minute.
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Pull down menus are menu lists which appear onscreen when a
choice is made from the menu bar. They temporarily overlay what is
on the screen, but after you have made a choice, the screen is
restored to its original appearance.

Typing Text

On some computers, soon after you begin to enter text, the message "Memory is
nearly full. Last chance to Undo" may appear. Just click on OK to clear this message
and continue on.

Notice the blinking bar, marking the insertion point, at the top left

under the ruler.

Now, type this sentence {or another of your choice):

"Put all the money in this bag and hurry up "

Press and hold the left arrow key untit the insertion point (blinking line)

is back at the beginning of the line. Noftice that the text disappears.

Typing with Max-10 is similar to typing on a typewriter, except it is

much more versatile and everything starts at the insertion point:

- Every character you type is added to your document at the
insertion point.

~ The left arrow moves the insertion point backward, removing what it
backs over.

— The ENTER key moves the insertion point down to the beginning of
the next line.

Key Repeat

On the Color Computer 3, the characier keys (letters, numbers,
punctuation, ENTER, and the space bar) repeat when you press and
hold them. In this manual, unless the insiructions say "press and
hold", "press” means 1o strike a key lightly as you would when typing.

Word wrap is a Max—10 feature that automatically moves the insertion
point and the word you're typing at the right margin to the beginning
of the next line if it does not fit. Do not use ENTER to move {o the
next line when your typing reaches the right margin, let Max-10
do it for you.

Type the following without using the ENTER key. If you make a
mistake, backspace with the left arrow and retype.

Victory is mastering those balmy tradewinds and staying upright
on a windsurf board.

Always let Max-10 end words at the right margin unless you want to
end a paragraph or skip a line.

Word wrap is more than just a conveniert feature to speed typing. it is
used to readjust spacing in paragraphs when you make a change
such as when deleting a sentence, resetting the margins or adding a
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word to a line.
You can only add text at the insertion point, so you must position the
insertion point first.

» Position the pointer at the beginning of the paragraph you just
typed and click the mouse button.

Notice that the pointer changes shape when you move it into the
document. You can select the insertion point anywhere within the text.
Type this text and put a space after it.

Learning how to scuba dive in the silent world beneath a
gorgeous turquoise sea.

Look at the way the paragraph changed. Notice that Max-10 has
readjusted it to make room for the added text. That's how Max-10
uses word wrap; if you end each line with ENTER, it won't be
readjusted when you add or remove text from the paragraph. If, out of
typewriting habit, you used ENTER at the right margin when you don't
have to, don't worry, you'll learn how to correct this later on in the
chapter.

The ENTER key

Next you'll use ENTER to skip fines and type a list, ending those short
lines of text before the right margin. And since you'll add text at the
end of your document, the insertion point must be there before you
can type anything.

» Now position the pointer after the period at the end of the
paragraph and click the mouse button.

» Press ENTER twice to skip a line. You could also skip a line by
positioning the pointer below the last line of text and hitting ENTER
once.

Remember, ENTER is a key that repeats if held down, so if you have
too many lines after hitting ENTER, just backspace with the left arrow
to remove them.

» Now type the following list (or any other short list you can think of).
Use the ENTER key to start each new line. Backspace and retype if
- you make a mistake.

Monday:

1. Scuba diving
2. Windsurfing
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3. Water skiing

Using ENTER actually inserts an invisible character called a line feed
into the text. As you can see, ENTER can be used to end a line before
it reaches the right margin. It is also used to end a paragraph or to
leave a blank line in the text. Press ENTER once to move the insertion
point to the beginning of the next line; press it twice to skip a line.
Backspace to remove the effects of ENTER by removing the invisible
line feed.

The Undo Command

If you don't like what you just typed (you can't swim, perhaps), you
can undo it using (what else ?) the Undo command. Here's how it
works.

» Choose Undo Last from the Edit menu.

To choose from a menu, first move the pointer to the menu title

and click once (briefly press mouse button) on that title, then

move the pointer down the menu (a bar marker will highlight the

selections) and click on your desired selection.

In this example:

1) Position the pointer on Edit menu title

2) Briefly press mouse button (Edit will blink)

3) Move the black bar to “Undo Last c¢Z" (we will explain "cZ" in a
moment)

4) Press the mouse button again.

If you've ever used the CoCo Max painting program, this should be old

hat to you.

Notice that the list is gone. Undo undoes the typing you've just done

(including backspacing) back to the last click of the mouse.

If you change your mind and want to return to the way it was before,

you can simply undo the Undo command, (it will show up on the

menu as Redo Last). Go ahead and try this: you will need your text

again later on.

Many commands can be activated with the control (CTRL) key instead

of using the mouse. If you are a fast typist you may prefer this method.

Remember the "cZ" at the end of the line? It means "control-Z" (hold

down CTRL and Z keys at the same time) it is a quicker way of

executing the Undo command.

You've just created a document, not a very big one, but it's still a
document. And you've been introduced to most of the basic Max—10
typing features.

Now, let's jearn about the ruler and how to use it to set the format of
text.
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Setting the format
Setting the text format means setting the margins, tabs, line spacing
and text alignment.

indentation marker

tab marker margin marker

& === =sE

|

tab well spacing boxes alignment boxes

The ruler

At the top of a new document, Max-10 provides a ruler with a preset
format which sets the left and right margins, justification and the tab
positions for the text that follows. You may keep it as is or change it to
suit your needs. Notice that the text you typed is aligned at the left
margin. This is called left justification (or left alignment). As you
change the settings on the ruler, they affect the text to the end of the
document (which is the last typed character, including ENTER) or to
the next ruler. Later, you'll learn how to insert multiple rulers to vary
the format in different parts of your document, to create tables,
indented paragraphs or centered titles.

Hint: If you are creating 2 document and you want to experiment with
various ruler settings, it is a good idea to make a copy of the present
ruler in case you later decide you want to keep everything the way it
is. See the section on “Using the Indentation Marker" for instructions
on inserting a ruler.

Changing Margins

The margin is the white space at the right or left edges of the text on a
page of a document. In some cases, however, an indentation marker
is used at the extreme left of a page with the actual margin to its right.
This .is a special case which is covered under the section on indents.
Top and bottom margins are one inch high. This cannot be changed

. from within Max-10. The section on printing in the "Document”

chapter explains how to change top and bottom margins.

» Drag the right margin marker to the 6%z inch mark on the ruler.
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To drag a marker: Position the pointer on the marker, press and hold
the mouse button, drag it to the desired position then release the
mouse button.

Just to get a feel for the different text format options, try dragging the
tab set and margin markers. Also click on the different text justification
boxes to see how the text looks under different conditions. Notice that
the text is reformatted immediately.

If the ruler becomes highlighted (appears reversed) when you make
any ruler changes, it's because you've selected it accidentally. To
clear this, just position the pointer elsewhere in your document and
click. "Selecting” is covered later in this chapter.

> Try to drag the right margin marker past the tab that's at the 52
inch mark. You can’t drag a margin marker past a tab marker and
leave it there, because a tab beyond a margin is pointless. If you try to
drag the margin marker past the tab marker, it will move below the
level of the tabs and when you release the mouse button, it goes back
to its original position.

» Drag the right margin marker back to the 62 inch mark.

Notice that on the left are two other markers - the left margin marker
and the indentation marker. When you want to change the left
margin of a document, you'll move both these markers, one at a time.
The margin marker affects any word wrapped text and aligns it at the
left margin. The indentation marker affects the first lines of paragraphs,
or single lines when the previous line was ended with ENTER. You'll
use the indentation marker later in this chapter.

» Drag both left markers, one at a time to the 1V2 inch mark.

When the indentation marker and the left margin marker are in the
same spot and they must both be moved, it is easier if you drag the
margin marker first. But if you carefully position the pointer on either of
the bottom angles of the lower triangle, you can drag the indentation
marker first. it takes a little practice.

If you begin to drag and see an outline of an empty triangle, you've
inadvertently picked up a tab. Just drag it down until the tab *pops off*
the ruler, then release the mouse button and try dragging the margin
markers again.

Changing Line Spacing

» Set 1V2 spacing by positioning the pointer on the middle box and
clicking the mouse button. Everything you typed now appears in 12
line spacing.
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> Click on the double-space box. Now everything is double—spaced.

Using the Scroll Bar

When you double-spaced your document, the bottom of the
document moved out of view. To move it back into view, simply scroll
the document by using the scroll bar. The scroll box shows you the
relative position, in the entire document, of the part of the document
that's now in the window. You can drag the scroll box to go quickly to
another place in the document. For instance, to go to the middle of
your document, drag the scroll box to the middle of the scroll bar.

If you drag the scroll box to the end of the scroll bar, Max-10 scrolls to
the end of the last page in your document. (It will be empty if you
haven't typed there.) Just scroll up a bit to where your text ends. A
review of scrolling techniques is given in Chapter Two of this manual.
Note: If you click on an item on the ruler that has scrolled partly off
screen, it will scroll fully back onto the screen so it can be seen.

»> Press on the up arrow on the scroli bar until you see the top of the
ruler. (to press: position the pointer and hold down the mouse button
until Max—10 completes the action you want.)

» Click on the single space box to see the whole document.

Changing Alignment

» Center lines between the margins by clicking the center—alignment
box. Note that a single line will be centered between the indentation
marker and the right margin.

» Now, click the right alignment box.

As you can see, everything lines up at the right margin. This is easier
to see when done on short lines. Remember, if you make a mistake,
the Undo command will undo most mouse actions (like choosing from
a menu) and typing errors. Keep in mind that (with a few exceptions)
you can only undo your last action, so click on Undo before you do
anything else. Now, click the full-justification box.

Justified text is text that is aligned with both margins. The words are
automatically spaced so all lines are of the same length. You will see
that text is evenly spaced across each line and justified at both
margins except where you ended lines with ENTER. You can fully
justify only word-wrapped lines. If you can't see the difference
between fully justified and left—aligned text, try clicking back and forth
between the full-justification box and the left-alignment box and
looking closely at the differences. As an example, notice that text in
this manual is fully justified.
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» Click on the left—alignment box to get back to the usual alignment.

There are two more items on the ruler to be introduced-the tab
markers and tab wells.

Using Tabs
A tab marker performs the same function as a tab on a typewriter: it is
used to align columns.

» Drag the tab marker from the 52 inch mark to the 5 inch mark on
the ruler.

To drag a tab from the tab well: Position the pointer on the tab well.
Press and hold the mouse button, and drag an outline of a tab up to
the inch scale of the ruler, in this case the 5 inch mark, then release
the mouse button.

Just as when you drag other markers or the scroll box, you don't have
to be too careful about the path you use while dragging tabs.
However, if you release a tab when it's still off the ruler, it will
disappear. Eight tabs are stored in the well and when they are all
used, (the well is dry) the tab icon will disappear.

» Place the insertion point, if it's not there aiready, at the end of the
list after the word "skiing". Press ENTER twice to skip a line.

Remember that the ENTER and Tab (right arrow) keys are character
keys and will repeat if you hold them down. So press them lightly;
though you can always backspace if you make a mistake. Type:

Early Lunch.

» Press the right arrow and type: 10:45

> Press ENTER.

Always use ENTER to end a line of a table. You can just use the Tab
key (right arrow) to skip to the next tab on the next line, but you may

get a strange-looking table if you have to edit it later.

> Type: Car Rental:
» Press Tab and type: $36.98

Like ENTER, Tab inserts an invisible character in a line. If you

backspace after you've removed the first character after the tab, you'l
remove the tab character and move the insertion point to the end of
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the text at the previous tab.
Try it and see what happens.

» Backspace seven times (using the left arrow, remember?)
The insertion point should now be just after the "I" in “rental”
» Press the tab key and retype: $44.98

Note: If no tabs are set on the ruler line, then pressing the right arrow
key inserts an "unjustifiable space” in the line. With full justification
set, type some text almost to the right margin. Then hit the spacebar
until you wraparound to the next line. Notice that Max-10 widened the
spaces in order to justify the text. If you repeat this, but instead of
hitting the spacebar, you hit the right arrow (with no tabs on the ruler),
this space will not be changed.

This introduction to tabs gives you the basics. You'll work with tabs
again in the second part of this chapter when you edit a document.

Editing Text
Editing means making changes to the text. It can be anything from
correcting a few typos to completely rewriting the document. in this
section, you'll edit text by first selecting it then performing an action on
it, either by typing or by choosing a command from a menu.

File Edit Search+ Layout Font Style k
Chapter Four
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Selected text appears with colors reversed
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Selecting Text

Making a selection is how you tell the computer what area of text you
want to work on. With Max-10, you'll select text to work on by
dragging the pointer across it. As you do this, you will notice the color
of the text is reversed.

» Let's select the words "Early funch®:

To select text: Position the pointer just in front of the text and hoiding
the mouse button down, drag the pointer across the text, and then
release the mouse button.

The text is highlighted to show that you selected it.

Note: There is a shortcut to select a single word: double click
anywhere on that word. To double click: position the pointer on a
word and hit the mouse button twice in quick succession.
Changing Text Style

Now, you'll do something to the selected text: you'll change its style. A
style changes the look of text, making it bold, italic, underlined, and so
forth. The text style should not be confused with the font. Changing
the font will change the dimensions of the letters, but underlined text
will remain underlined, bold will still be bold and so on...

» Choose Bold from the style menu.

"Early Lunch” is now in bold letters and still selected, so you can
change it again. (It becomes unselected only when you select
something else.) Notice that in the Style menu, there is a check mark
next to Bold.

Since you can combine styles, go ahead and choose another one.

& Choose Italics from the Style menu.

The text is italicized, and you could change this to any other style.

But instead, change the font size to see another effect you can create
with this menu.

» Choose Ft. Worth 24 from the Font menu.

Too big 7 Remember the Undo command !

» Choose Undo from the Edit menu.

"Early Lunch" is now back to its original appearance. When the Undo

command is used with font/style changes, it returns the text to its
original condition before any changes were made.
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Replacing a Selection

When you make a selection or click to set an insertion point, you
unselect the previous one as it is only possible to make one selection
at a time.

» Select the sentence at the beginning of the document.

Position the pointer at the beginning of the text. drag across the lines
to the end of it, then release the mouse button. You could also have
selected the text by dragging from the end of it to the beginning.

This time, you'll act on the selected text by typing something.

> Type your name.

When you select text and start typing, what you type replaces the text
you selected. After text has been selected, it may be cut, pasted,
copied or its font and style may be changed to another. Remember,
you can undo this from the Edit menu.

» Choose Undo Last from the Edit menu.
Max-10 undoes your typing and restores the original text.

Experiment a little with the skills you've learned. You know how to use
the special typing features, how to set a format on the ruler, how to
select text and change it, and how to select the insertion point to add
or remove text anywhere in your document.

Go ahead and practice making a selection and working with it. Use
the commands in the Style or the Font menus.

There is more to learn about selecting and using the Style and Font
menus. Chapter 2, "Using Max~10", answers the questions you may
have. All the Max-10 word processing procedures, from basic skills to
advanced tasks, are presented there with explanations. In the next
part of this chapter, you'll build on the basic skills you now have as
you edit the text of a document.

Starting another Document

When you've finished experimenting, you should erase this document
in order to begin the second part of this chapter, "Editing a
Document”.

» Choose New from the File menu and click on the OK button.

The screen clears and you are shown the ruler with the startup tabs
and left justify is selected.
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Editing a Document

What follows is a guided tour through the process of opening and
editing an existing document saved on the disk. You're going to edit
text and alter the format by using Max—10's features. When you're
finished, you'll save it as a separate document and keep the original
for someone else to practice on.

if you have more than one drive

Max-10 starts up with the assumption that you will save you
documents on drive zero. If, however, you wish to use another drive,
click on File Drive... in the File menu and then select the drive you will
save and load documents from by clicking on the appropriate button.
If you click on the Verify Data button, Max-10 will verify that
documents are saved to disk safely.

Opening an Existing Document

» Choose Load... from the File menu.

A dialog box appears with a list of the files on the disk. Up to 32 files
will be displayed. The display also indicates which drive is in use and
how many granules are available.

» Click on "vacation"

A copy of the document appears.

Inserting Text

Once you've loaded a document, you can insert characters including
spaces, Tabs and Line Feeds at the insertion point. Practice again by

making the following correction.

» Click on the down arrow on the scroll bar until you can see the first
two paragraphs. ’

> Put the'insertion point at the beginning of the second paragraph by
positioning the pointer in front of the number and clicking.

» Press ENTER once.

You've inserted a blank line, and the whole document has moved
down to accomodate it.

Removing Text

Until now, you've been removing text (including Line Feeds and tabs)
by backspacing over it. However, for text that you've already typed, it's

Max-10 Page 17 @




faster to select what you want to remove and then use one of two
methods to remove the whole selection. One method is to use the Cut
command in the Edit menu; the second method is to backspace over
it or to hit the CLEAR key. You'll be shown the second method a little
later.

» Scroil to the next windowful by clicking once in the gray area below
the scroll box.

» Select the text "in your own way.,” by dragging across the text or by
double clicking.

The selection is highlighted, ready for the next action.
» Choose Cut from the Edit menu or hit CTRL X.

The text disappears.
Notice how Max-10 has reformatted the paragraph to account for the
missing words. This is one of the functions of word wrap.

The Clipboard

When you cut text, Max—10 moves it to a holding area called the
Clipboard. Because you can put the contents of the Clipboard back
into your document, cutting is the first step in moving text.

If you have a 128k CoCo, the clipboard is stored in memory if it is
below a certain size. However, when clipboard size increases beyond
200 bytes {about one line of text), Max—10 will save it to disk instead.
with a 512k Computer, the Clipboard is kept in memory unless you
want it saved to disk. If the Clipboard is being saved in memory, the
RAM Clipboard entry in the Flle menu will be checked off. By clicking
on this entry, you can force the Clipboard to be stored either in
memory or on disk.

You can see the contents of the Clipboard by choosing Show
Clipboard from the Edit menu. You exit Show Clipboard by clicking
the mouse button.

Moving Text in your Document

You move text by selecting and cutting it from one place and then
pasting it somewhere else that you select.

» Scroll the document up to see paragraph 1 again.

» Select the sentence "Take in the sights.” in paragraph 1.

» Choose Cut from the Edit menu.

Max~-10 removes the selection and places it on the Clipboard.

Max-10 Page 18 @

» Choose Show Clipboard from the Edit menu
There's the selection you just cut.

> Click to exit the Show Clipboard function.
» Select the insertion point at the end of the same paragraph, and
type a space with the space bar.

= Choose Paste from the Edit menu.

Since Max-10 pastes only a copy of the Ciipboard contenis, you can
paste the same thing again. Just select the new insertion point and
choose Paste. Only another Cut or Copy will change the contents of
the Clipboard. On a 512k CoCo, turning the power off erases the
Clipboard if it was not saved on disk. On a 128k CoCo, the Clipboard
will be stored on disk.

Saving the Clipboard

if there is a check mark next to the RAM Clipboard entry in the File
menu, the clipboard will be lost when the computer is turned off.
However, it can be saved to disk. If you have two or more disk drives,
the drive used for the clipboard may be changed with the Clipboard
Drive command in the Edit menu. This menu choice works just like
the File Drive... command.

*> Choose Save RamClip from the File menu.

A dialog box appears. If you wish to save the clipboard with the name
already in the box, just hit ENTER or click on OK. Otherwise type in
the name you want the clipboard saved under and hit ENTER and it
will be saved on disk for future retrieval.

Copying Text

Copying text works like cutting it, except the text isn't removed from
the document. You select what you want to copy (by clicking on the
beginning and dragging) then choose Copy from the Edit menu,
select the insertion point, and choose Paste from the Edit menu.

You can paste copied text repeatedly until you change the contents of
the Clipboard with another Copy or Cut.

Replacing Text

Now you're going to replace "painting”, the seventh word in the
second numbered paragraph, with "pottery”. Although you could Cut
"painting” and then insert “pottery”, you've already learned a faster
way to replace text: simply select it and type its replacement.
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» Select the word "painting” by double clicking on it.

> Type: potiery
"painting” disappears and "pottery” takes its place.

Removing Selected Text: a quick way

Cutting is one way to remove selected text. Using either the
backspace or the CLEAR key is another. Cutting saves text to the
Clipboard for later use, but deleting it with the CLEAR key or
backspacing over it does not. Notice that when you delete with either
the CLEAR or the backspace key, any extra spaces around the
deleted words are removed.

When you do this exercise, the paragraph won't readjust as it did
before. You'll see why in a minute, First, let's try another selection
technique.

» Select "boat rides.” in the same paragraph of the brochure by using
Shift-Click.

To select with Shift-click: Select the insertion point by positioning
the pointer and clicking. Next, position the pointer where you want to
end the selection then whife you hold down the Shift key, click the
mouse button.

You can use this technigue for making long texd selections by scrolling
before you shifi-click. See the section “Selacting” i Chapter 2 for a
summary of all selecling methods. Notice also that if you click and
drag the mouss bution 1o select (the way you learned before), the
screen also scrolls as vou move down or up.

Mow remove the selection by prassing the lelt arrow once.

The selected toxt ég h[ ieni inated. Backspacing over a selection dossn’t
place i on the Clipl £0 backspacing or hitling C‘M: R iz a useful
way o remove v’w il keap the contents on the Clivboard to
paste later.

Removing unwanted Line Feeds

Oceasionally, you'll add or @"@mmf@ text, and a p aragrap H won't
readjust. In ithe paragraph you're editing, a Line Feed (used on
purpose to show the effect) is smm ng Max-10 from fil ﬂmg in the
remaining texd o form a '@r@pm looking paragraph. if you remove the
line feed, the paragraph will be readjusted.

= Select the insertion point at the beginning of the next line, which
starts with "Or”.

» Backspace.
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The two parts will merge to form a paragraph.

Changing the Document's Format

You've learned to use most of Max—10's text editing features. Earlier
you learned how o alter the format of a document by changing
settings on a ruler.

To change the format of different paris of a document, you use the
Layout menu to insert a ruler above the section you want to change,
and then you change the settings on the new ruler, Those settings are
in effect up to the next ruler or to the end of the document. You can
have many rulers in a document, one for the main body, a different
one for indented material, another for tables, and 3¢ forth.

Using the indentation Marker

When you changed the ruler settings in the first part of the chapter,
you saw those changes affect the entire document. Now, let's indent
only the three numbered paragraphs. To avoid indenting the rest of
the document. you'll insert two rulers, one at the beginning and cne at
the end of the text to be changed. Then, you'll change the margin
settings only on the first. As you'll see, the changes will affect text only
up to the next ruler.

= Select the insertion point at the beginning of paragraph 1.
» Choose Insert Ruler from the Layout menu.

This inserts a copy of the present ruler at the selection point.

» Scroll down to the last two paragraphs.
» Move the insertion point to the beginning of the last paragraph.
» Choose Insert Ruler again.

You get a copy of the preceding ruler.

» Go back to the first ruler you inserted using the Scroll Bar.

> Drag the first tab marker down off the ruler and release it. It will
disappear.

> Drag the indentation marker to the 2-inch mark.

» Drag the left margin marker to the 212 inch mark.

Note that the paragraphs are reformatted. The numbers are aligned
with the indentation marker, and the rest of the paragraph is further
indented and aligned with the left margin marker. This happens
because the left margin marker acts as a tab only on the first line of
the paragraph and the words align themselves with it.

> Move the insertion point to the end of the third paragraph.
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» Hit ENTER twice to skip a line.

Notice now that when you hit ENTER, the insertion point aligns with
the indentation marker.

» Enter this paragraph. Press tab (right arrow) after you type "4." and
remember not to use the ENTER key until the end of the paragraph

4. Whatever your fancy, we've got the sport. We offer:
Scuba diving, snorkeling, water—skiiing, sailing, volleyball,
horseback riding, jogging, Ping—-Pong and archery.

Notice that the "4" is aligned with the indentation marker and the
remaining lines are aligned with the left margin marker. Now, we are
going to insert some text into the table at the bottom of the document.

Inserting a Column in a Table

Go to the table at the end of the document and drag a tab from the
tab well to the 3-inch mark on the ruler above the schedule. The last
column will move under the new tab because Max-10 lines up tabular
text with the most recent set of tabs. This means that if you insert a
tab marker between two already existing ones, the columns on the
right will move one tab to the left. To insert a new column under the
new tab while keeping the original where it was you must move to the
last position before the new tab, hit the right arrow key and enter
whatever text you wish. This will put the columns on the right back in
their correct places.

e.g.:

» Place the insertion point just after “Breakfast” and press the right
arrow.
» Type "(too early)"

You will see that "(too early)" now goes in the middle between
“Breakfast” and "7:30 - 9:30"

Hiding Rulers

To make the rulers invisible, simply go into the Layout menu and click
on Show Rulers. Remember: it was selected before so clicking on it
will unselect it and the rulers will vanish. To see them again, just click
Show Rulers back on.

Rulers can be selected by clicking on the inch scale. They may also
be copied and except for the first one at the top of the document, they
can be removed or replaced.

Saving Text
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It is a good idea to save your work every 10 to 20 minutes or so.
Should there be a power failure or a computer system failure, at least
you won't have wasted too much time typing and editing.

» Choose Save... from the File menu

The command Set Drive in the File menu is used to assign the drive
which will be used to save your document. If you have more than one
drive, go to the File menu and click on Set Drive and then click in the
button corresponding to the drive you want to use. Now you can save
your document. Notice that if you only have one drive, Max-10 will
automatically save on drive 0. If you click on the Verify Data box,
whenever a file is saved, Max—10 will verify that it was saved correctly.
A dialog box appears with the prompt: "Save Document As:" with a
space for the name of your document. A default name will appear in
the dialog box. If you want the document saved under this name,
simply click on the Save button to save it again under the same name.
Otherwise type a new name into the box and either click on the
mouse or press ENTER. Max—10 will check to make sure there is
room on the disk and if there is, your document will be saved. If not,
you will be told that the disk is too fulil. In this case, replace it with
another formatted disk. Max-10 also checks to see if you are
overwriting an existing file.

Printing

Remember that Max—10 must be configured to your particular printer.
See the section on configuring Max-10 at the beginning of the
manual.

» Choose Print... from the File menu.

» Click on Full Graphic Output: this is the usual print mode.

» Hit Enter or click on OK and printing begins.

Notice that the scroll box moves down the scroll bar to indicate which
area of the document is currently being printed. If you need to cancel
printing for any reason, simply hit the Break key. To pause the print,
hold down the spacebar (it may take about 2-5 seconds before it
pauses); when you are ready to continue, just press it again.

Moving Ahead...

Continue to experiment with Max-10. Write that letter you've been
putting off for so long. or get a start on the Great American Novel. You
will find that the more you use the features, the quicker it is to do
something useful. In the following chapters you will learn about the
other features of Max—10.
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Working with Max-10
Basic Skills

This chapter reviews and details the tasks covered in Chapter One
and presents other Max—10 features you should know about.

Using the Mouse

- Click to select or activate something. To click, position the pointer in
the desired spot and press and quickly release the mouse button

—- Press to cause a continuous action. To press: position the pointer
and press and hold down the mouse button.

- Drag to select or move something around. To drag: position the
pointer and move the mouse while holding down the button.
Release the button at the end of the action. You can usually cancel
a drag by moving the pointer back to where it was at the beginning.

— Double-click to select a word. To double—click: position the pointer
and press and release the button twice in quick succession. If you
double-click on a word and then drag the mouse, Max—10 will
extend the selected area one word at a time.

— Shift-click to select an area of text. To use shift—click: mark the
beginning of a selection with the insertion point and move the
pointer to the end of the selection area. At this time, hold down the
shift key and at the same time, click the mouse button.

Using the Scroll Bar

Scrolling is used to show different parts of the document on the
screen. You can imagine the document to be a long sheet of paper
that you can roll past a small window.

To scroll up or down one line: Click the appropriate arrow at either
the top or bottom of the scroll bar or hold down the CTRL key and
press either the up or down arrow key.

To scroll up or down continuously one line at a time: Move the
pointer to the appropriate scroll arrow and press.

To scroll by screenfuls: Click in any part of the scroll bar above or
below the scroll box, depending on the direction you want to scroill.
This can also be accomplished by holding down the ALT key and
pressing the up or down arrow keys.

To move te any part of the document: Drag the scroll box up or
down the scroll bar to the position which approximates the section of
the document you want to go to. The page number in the bottom left
shows the page that the box is currently passing through.
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Editing

In Max—10, editing involves selecting something and performing any of
a variety of actions on it by typing or using the commands. A Max-10
document may be composed of text, page breaks, rulers, headers,
footers and pictures. In this section you will find the methods of
selecting the elements of a document summarized. Note that the Edit
menu commands may also be performed by control keys.

Any of the operations that follow may be undone with the Undo
command. If it is not possible to Undo an action, Max—10 will not allow
you to select the Undo command and it will show up dim gray in the
menu.

TextEdit: TextEdit is a Max—10 feature that allows the use of standard
document editing commands in dialog boxes:

ENTER terminates a line if any text was entered in the box and
executes the command. It is identical to clicking on *Ok".

Tab (right arrow) goes to next box if there is one.

Break can be used instead of clicking on “Cancel"

If, upon entry, anything is in the dialog box, it is highlighted and may
be used as data for the command. For example: suppose that five
minutes ago you looked for the word “CoCo" in your docurient. If you
re-entered the Find/Change dialog box, you will see that the word
"CoCo" is still there and is highlighted. You can now search for that
word without having to type it in again: just hit ENTER or click on
Find. If you do wish to enter another word, however, just type it in.
Whatever you type will replace any selected text. Text within a dialog
box may be selected as would text in the document. Cut, Paste and
Copy will work in the dialog box. but only using their control key
equivalents (ctrl-X, ctrl-V, ctrl-C). There is no Undoing in a dialog
box.

Selecting

Selecting is using the mouse to indicate an area in document which
will be acted upon. Max-10 indicates a selected region by reversing
the colors with respect to the surrounding area. The insertion point, a
selected position, is marked by a blinking vertical bar. In the previous
chapter, you learned to select text using the mouse, now we learn that
the keyboard can also be used.

To select the Insertion Point: Move the pointer with the mouse to the
desired spot and click the button. The insertion point can also be
moved by holding down the CTRL key and pressing any of the arrow
keys.

Note: to place the insertion point to a point just before a picture, click
in the left margin adjacent to the picture.

To select words: Double-click on the word. This selection may be
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extended by dragging the mouse or by double-clicking and then
using shift—click.

To select text: Drag along a line of text in either direction or drag
across multiple lines in any direction. In the event that you drag
beyond the bottom or top of the window, the document will scroll to
allow you to continue seiecting text. To select text using the keyboard,
hold down the ALT key and press the left or right arrow keys to select
the desired region.

To select lines: Click in the left margin and drag downwards the
amount of lines you want selected.

Quick selection of large areas: Select the insertion point at one end
of the area and then move to the other end of the area. At this time
you may shift—click to select the entire area.

To select an entire document: Simply move the scroll box to the top
end of the document and set the insertion point there; next, move to
the bottom, again using the scroll box, and shift—click to select the
entire document.

Extending or shortening a completed selection: Place the pointer
on the point where you want the selection to end and while holding
down the Shift key, click to complete the selection. For example:
Select the first two lines of the document. Now let's extend the
selected area to include the next three lines. Move the pointer down to
any point on the fifth line, and while holding down the shift key, click
the mouse button. Notice that the highlighted area has been extended
to the position of the pointer.

Selecting a Ruier: Click anywhere on the scale. To select text and the
ruler, drag from the scale of the ruler across the text to the desired
point. If at this time you try to change the setting on the ruler, it will
temporarily return to its normal color as you change tabs, or margins,
etc.. then revert to the reversed colors to indicate it is still selected.

To Select a Picture: Click anywhere on the picture. If the picture was
selected with other text, rulers, page breaks or pictures, it will appear
reversed. If only the picture was selected then it will appear with a
black border around it.

To select a Page Break: Click inside the empty space before the end
of the page and it will change color to indicate that it is selected.
Headers, footers and the dashed lines below page breaks may not be
selected.

Note: If a selected area or the insertion point is partly offscreen, hitting
the Break key will scroll it completely onto the screen.

Inserting

Inserting Text: Select the insertion point and type the new text. The
text typed pushes the original text over to make room.

Inserting Blank Lines: Place the insertion marker at the correct place
and hit ENTER - once if the insertion point is a the beginning or end

Max—10 Page 26 EaLorwarE

of a paragraph - twice if anywhere else in the paragraph. Note that
hitting ENTER or inserting a picture, a page break or a ruler within a
paragraph will split the paragraph in two.

Inserting an "unbreakable" space

Normally, if a space is inserted within a word, Max-10 will then
consider that word to be now two words separated by a space. As a
result, the words may be on different lines if the first one ends at the
end of a line. If you wish to keep words together at line and page
breaks, instead of separating them with normal spaces, it will be
necessary to insert a hard or unbreakable space. This is done by
hitting ALT-spacebar (hold down ALT and press the spacebar). Max-
10's "garbage” character (ASCIl 127) will then appear onscreen to
indicate a hard space. This will print normally on your printer, but if
you want it to appear "invisible” as would a normal space onscreen,
click on [Jj] as Space in the Style menu. When this menu option is
checked off, the hard space will not show up as a black box on the
screen. Note that if you import an ASCI! file and you want to delete the
[l characters Max-10 has inserted in place of those characters it
does not recognize, you will have to deselect this menu choice by
clicking on it again.

Inserting a Ruler: With the insertion point at the correct place, choose
Insert Ruler from the Layout Menu. The ruler will be inserted at the
insertion point (or if anything else was selected, the ruler will replace
it). To make a headline: insert two rulers and click in the left margin of
the second ruler to position the insertion point. Then enter the text and
change the first ruler to format it. The second ruler will preserve the
format of the text below the headline.

Removing

Removing using the Cut command: Select what you want removed
and choose Cut from the Edit menu. The area removed is now off the
screen and saved on the Clipboard. The Paste command may be
used to put it back anywhere in your document.

Removing using the Left Arrow (Backspace) or the CLEAR key:
Select the insertion point and using the left arrow, backspace over
characters one at a time. Alternatively, select what you wish removed
and press the left arrow once— note that this does not piace it on the
clipboard but it can be Undone. Note also that it is not possible to
backspace into a ruler, picture or page break. The CLEAR key can be
used as an “intelligent” delete key. When text is selected and the
CLEAR key is hit, the selected text is deleted as with the left arrow key,
but any extra spaces which would have been left between words are
removed.

Removing a Line Feed Character: Place the insertion point at the
start of the line after the one ending with the unwanted line feed and
press backspace once. When you remove a line feed within a
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paragraph, the line will readjust to follow the format specified on the
ruler. Removing line feeds at the beginning or ending of a paragraph is
also a way to merge that paragraph with the one before or after it.

Replacing

Anything that can be selected can be replaced (except the first ruler).

To Replace: Select what you want replaced and then you can:

— Type new text.

— Paste the contents of the Clipboard over it using Paste from the Edit
menu.

— Paste the contents of an entire file using the Paste Flle command
from the Edit menu. To do this, click on Paste file in the Edit menu
and, choosing from the list that appears on the screen, click on the
file you want to paste. Max—10 will paste this file into your
document, overwriting the selected area.

- Insert a ruler using the insert Ruler command off the Layout menu.

- Insert a page break with the insert Page Break command also from
the Layout menu.

— You can also replace the selection with nothing by pressing the
backspace or CLEAR key once.

Moving and Copying within a document

As with replacing, you can move or copy almost anything inside a

document that can be selected: text, pictures, rulers (the first ruler

may not be moved) etc...

To move or copy:

- Select the appropriate region of the document. Text that is to be
moved or copied will acquire the same format (margins, rulers, etc.)
as text in the region where it is to be moved but it will keep its size,
font and style. If you want to keep the text in its original format, it will
be necessary to insert a ruler just before it and select this ruler aiong
with the text to be moved. Note that if you want to copy a ruler, you
must click on its inch scale to select it.

- From the Edit menu choose Cut if you want to move an area or
Copy to make a copy of it. This will save the selection on the
Clipboard.

- Place the insertion point where you want the text to go.

- Choose Paste from the Edit menu and a copy of the region selected
will appear at the insertion point and the insertion point will be
relocated to the end of the newly inserted material. Note that after
cutting text, it is not necessary to immediately paste it. As long as
nothing else is selected, you may continue to type or edit the
document until you decide to paste the selection somewhere. It is
also possible to replace one selection with another. To do this,
select the first region of text and Cut or Copy it to the Clipboard.
Next select the region of text which is to be replaced and choose
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Paste from the Edit menu (or hit CTRL-V) and the selected region
will be replaced with the contents of the Clipboard.

Moving and Copying between different documents

This section deals with moving and copying selections between
different documents.

To Move/Copy between documents:

A) To move text or pictures from the document presently open (the
one you are working now) to another one:

First select the desired region from the document presently open and
choose either Copy or Cut from the Edit menu. This wili place the
selected area on the Clipboard. Next exit the current document with
the New command (the document will be lost if it has not been saved)
and load the document to which you want to transfer the selection.
Now select the insertion point where you want the selection to go and
choose Paste from the Edit menu. The selection is now inserted into
the new document. Note: if you have to change disks on a 128k
computer, be sure that the disk with the Clipboard is put back in the
drive before you Paste!

B) To move text/pictures from another document into the one
presently loaded.

Choose Paste File from the Edit menu. A list of documents on the
disk will appear. Click on the one you want to include in the document
you are working on and Max—-10 will paste it at the insertion point.

If you are not sure which of the documents on the disk you want to
include, you may use Show Flle to take a quick look at each of them
first. To use this function, click on Show File in the Edit menu. A list of
files will be displayed. Click on the one you want to look at and you
will see the first 212" of that document displayed onscreen. Click the
mouse button again to exit Show File.

Note: If. when moving text or pictures between documents, you are
about to exceed memory capacity, a message will appear. This is also
the case when:

— A paragraph exceeds 6000 characters.

- There are more than 480 paragraphs.

- The Undo command is about to be temporarily disabled. When you
get this particular message, you are being informed that at this time,
you may Undo your last change. After this point it will no longer be
possible to Undo the operation. Any later changes may be undone,
however.

Searching

The Find command in the Search+ menu is used to locate and select
any series of characters. It can also be used to move to a specific
place in the document by searching for a word or phrase near that
place. Usually, Max—10 searches for text without regard to fonts, styles
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or capitalization. Max-10 may not be used to search for line feed or

tab characters. The search begins at the current selection or insertion

point, goes to the end of the document and wraps around to the
beginning. finally terminating at the point at which it started.

Read the section on "Text Edit” for information on using the Text Edit

feature in the Find dialog box.

To Search:

- Make the insertion point the place where you want the search to
start. If an area is currently selected, then Max-10 will ignore that
area when it begins its search and will search from the end of the
selected area. This means that if the string you are searching for
may only be found in the selected area and is not anywhere else in
the text, then Max—10 will never “see" it. This is especially useful
when you wish to exclude a large area from the search to save time.

- Choose Find/Change from the Search+ menu and a dialog box
appears. Enter the text you want to search for in the "Find:* box.
After you hit ENTER the search begins. If your text is not found, a
message appears to tell you so. Click on the "OK" button in this
dialog box to clear the message.

- Case significant searches: Normally, when Max-10 searches for
text, the difference between uppercase and lowercase letters is not
taken into consideration (lowercase "a" is the same as uppercase
"A"). If you want to perform a case-significant search (i.e., capital
"A" is different from small "a"), just click on the "Match
Caplitalization” button.

- Matching words only: Usually, if you tell Max—-10 to search for a
group of letters, "up”, for example, it will return matches such as
"uppercase”, “hiccup® or “duplicate” because these words all
contain the letters "up”. However, by clicking on the Whole Words
Only button, Max~10 will only report if it finds the group occurring as
a separate word.

Searching and Replacing: Anything that can be searched for can be
replaced by Max—~10. If you choose to change all occurrences of the
text for which you are searching, the document is searched from
beginning to end and the search ends with the last change
highlighted. You can also choose to use the menu entries to find and
change each match individually. All search/changes can be undone.

To Search and Replace:

- Select the insertion point where the search is to start.

- Choose Find/Change from the Search+ menu. and in the dialog
box that appears. type the text you are searching for, and, without
hitting ENTER, using the mouse or the tab (right arrow) key, move
the insertion point to the "Change To:" box and enter what you want
the text changed to and hit ENTER. The text in the "Change to" box

Max-10 Page 30 EaLorwaRE

may be in any font or style you wish: Before you enter the Search+
menu, you may select the font and style you want from their
respective menus (see the section on "Changing the Style or Font").
Then, when you are in the Find/Change dialog box, click the "Use
menu Font & Style* button and an “X* will appear there. Now, when
the text is changed, it will be in the selected font and style. (if you
decide to change the font or style when already in the Find/Change
menu, you may exit using Cancel, make the font or style choices,
and then return to FiInd/Change). if you don't enter anything after
*Change to:", Max-10 will replace the designated text with nothing,
effectively deleting it. Max-10 will search through the document and
if it finds the text you have specified, it will highlight it and stop. At
this time you may return to the Search+ menu and make a choice.
- Find/Next (or CTRL-F) will get the next occurrence of the string.
- Change (CTRL-R) will make the desired change to this
occurrence.
~ Change/Next (CTRL-N) will make this change and find the next
occurrence of the string.

if you simply want all occurrences of the search string changed to
the “change" string, simply click on the Change All prompt in the
Find/Change dialog box and it will be done. In the event that no
matches are found, a message will pop up to inform you.

If you click on Change (or use CTRL-R or CTRL-N), only the most

recent change may be undone. However, if you choose Change All
then the entire set of changes can be undone.
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Changing the Format

Ruler Settings: When any of the settings on a ruler (margins, tabs,

spacing, etc.) are changed, those changes affect text between that

ruler and the next one (if there is another) following. If there isn't
another ruler, then those settings remain in effect until the end of the
document.

To Change:

» Margins: Drag the left or right margin marker to the desired
position. Note that if the margin marker "pops" back to its previous
position, this means that you are attempting to place it in an invalid
position.

» Indentations:

- No indentation— drag the indentation marker to the left margin
marker.

- Regular indentation (first line is indented to the right of the rest of
the paragraph)- drag the marker to the right of the left margin
marker.

- Hanging indentation (first line begins to the left of the rest of the
paragraph)— drag the marker to the left of the left margin marker. In
this case, the left margin marker will act as a tab marker and you
can use the right arrow key to move to it.

> Tabs:

—~ To change a tab, drag it along the scale of the ruler.

— To add a tab, drag one from the tab well to the desired position.

- To remove a tab, drag it off the scale until it pops down, then release
it.

» Line Spacing: Click the appropriate box. The choices are: double,
one and one-half and single spacing.

» Text Alignment: Click the appropriate box. The choices are: left
and right aligned. centered and fully justified.

Format Changes while Typing:

To change the format while you are typing in text, first decide where
you want the format changed and select the insertion point there. Next
choose Insert Ruler from the Layout menu and a copy of the
preceding ruler will be inserted. Using the information given before on
ruler settings, change the settings on this ruler as you wish then you
may continue typing and the text will be in the new format.

If you decide at any time that you want to reuse the previous format in
some other place in the text, you may copy the preceding ruler to the
appropriate place. See the instructions on "Moving and Copying within
a Document” previously in this chapter.

Changing the Format of Existing Text:
If you wish to change the format of an area of text without disturbing

Max-10 Page 32 @

the format of text beneath that area, first select the insertion point
where you want the new format to start. Next, choose Insert Ruler
and a ruler with the most recently set format will appear.

Now, move the insertion point the end of the last line of text whose
format is to be changed and choose Insert Ruler again. This will
preserve the format of the text that follows this point. You may now
change any of the settings on the first ruler you inserted and only the
text format between the two rulers will be affected. This is an excellent
way to create tables and other aligned text which have formats
different from the rest of the text.

Changing the Style or Font:

In Max-10, you have the choice of several text styles. Text may be
underlined, boidfaced, italicized and sub- or super- scripted.
Subscripting text lowers the vertical placement of characters on a line,
superscripting raises it. This is useful for footnotes or mathematical
and scientific writing. You should use smaller text sizes when using
superscript or superscript; otherwise Max—-10 may be forced to
increase the space between lines to make the text fit. There is also a
choice of several fonts in the Font menu. You may even load new
fonts from disk if you have additional font sets. The next section deals
with changing the font.

Text typed into the document will be in the font and style of the text
immediately preceding it unless you change style or size after clicking
to set the insertion point. Because a space is considered a character,
it is possible for a space to be a different style from the letter
preceding it. This could be the case if a line appears to have "too
much* text in it. To correct this, select the entire line and reset the font.
At any time, the present style and font are checked off in their
respective Style and Font menus. When the document is first started,
the style is preset to Plain Text and the font will be the first one listed
in the font menu.

To change Style or Font: Select the text to be changed, or select an
insertion point. Next, choose a style from the Style menu or by using
the control code (see the table at the end of the Glossary). A check
mark will appear next to the style(s) you chose. The fonts are changed
in a similar manner but they may only be selected through the menu. If
you have a disk with extra fonts, you may load them into Max-10. To
do this, place the font disk in drive 0 and click on Font Set... in the
File menu. This will display a dialog box with a list of font sets on disk.
Click on the set you want to load into memory. Fonts may only be
loaded from drive 0. When you click on Font Set, the file drive will
automatically be reset to drive 0. Although it is possible to load
different sets of fonts from the disk, Max—10 will only permit one font
set in your document at any given time.
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Colorware has created a large number of fonts. Call us at (203) 656-

1806 for details.

Notes:

1) When an insertion point is put into text, the font and style checked
off in the menus will be the font and style at that point in the text.
Changing the menu selections will change the font and styie at that
point in the document.

2) When Undoing after a font style change, the text will revert to the
original style no matter how many times it was changed. That is: If
you select a block of text which is, for example, in Script Bold, and
change it to Ft. Worth 10, then underiine it, italicize it, and then turn
off underlining, and then make the font Topeka and decide you want
to undo all this, choosing the Undo command will not do as you
may expect: i.e., change the text to Ft. Worth 10 italicized (which is
what it was before the last change). It will instead cancel all changes
and turn the selected block back to Script Bold. This is done so that
you may experiment with various fonts and styles without losing the
option to go back to the text in its original form.

To Remove a Style: Select the text as usual and, going into the Style
menu, unselect (click on the checked off style) the style you want to
remove. That style will be removed from the highlighted section. When
a selection has more than one style, you can remove a style by
choosing the menu command twice. The other styles remain and the
specified style is removed. Note that the styles will only be checked if
all the selected text has that style in common. If styles are mixed, then
no checks will show. To change the style of text as you are entering it
without taking your hands off the keyboard, remember that the
following control keys may be used to choose the appropriate style:
Control Key Style

Plain Text

Bold

ltalic

Underline

Superscript

Subscript

rICTwWvU

Working with Tables

Using Max-10, it is possible to create tables using the tab markers
and the tab (right arrow) key. Information in these tables may then be
edited without disturbing text in other columns as long as the editing
does not change the tabs or run into the next column.

To Create or Edit a Table: Drag a tab marker to the point on the ruler
scale where you want the table's column to align and repeat this for
each column of the table. To create the rows, press the tab key to
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move to the desired column and enter text. Pressing ENTER will take
you to the next line. Text may be selected and copied as usual. If text
which is inserted at a tab overflows to the next tab, Max—10 will push
text at that tab over to the next and so on until it finds a line feed
character at which time the text at the last column may wraparound to
the next line. If you remove the space between two columns in a row
of the table, the text at all columns to the right of the removed space
will shift one column to the left.

To remove a column from the table:

Select text on each row of that column and delete it using either the
Cut command on the Edit menu or the Backspace (left arrow) key.

To insert a column Into the table:

Move the tab markers to make room for the new column.

Drag a tab from the well to the position of the new column. The
columns to the right will move left to the position of this new tab. Do
not let this worry you. They will return to the correct positions when
you enter text.

Select the insertion point at the end of the preceding column or at the
beginning of the line.

Press the tab key, moving the insertion point to the new column.
Notice that the columns on the right are now back to where they were
previously. At the correct column, you may now enter your text.

Headers and Footers

Headers and footers are the areas in the top and bottom margins
where information such as page number, pictures, chapter titles and
so forth may be placed. There should be no indentation within a
header/footer. The left margin marker must be on top of the
indentation marker or problems will result. Headers and Footers may
be as long as five paragraphs or nine lines in length, whichever comes
first, but you will probably not need more than a few lines. In any
event, when you attempt to close the headerffooter, a dialog box will
"pop up® to warn you if you are exceeding the maximum length
allowed. If the menu choice, Show Header/Footer is checked off, the
headers and footers will be displayed onscreen:; if not, they will not
appear but will still affect the page layout. Click on this menu selection
to turn the header dispiay on or off.

To Create Headers and Footers:

Choose Edit Header... or Edit Footer... from the Layout menu. Your
document will disappear temporarily and a blank page will be
displayed. Enter the text you want to have in the header or footer on
this page. If you have trouble separating the header or footer from the
rest of the printed page because you cannot insert enough blank
lines, try using one and one-half or double spacing. To have the page
number displayed, enter three "#" characters (hold down the SHIFT
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key and press the “3" key) without spaces in between, like this: ###
(in some fonts this will appear as "£££"). While you are in the Edit
Header or Edit Footer mode, all the other editing functions are still
available.

Changing First Page Number:

Choose Set Page Number from the Layout menu. Type in the
number assigned to the first page and hit ENTER or click on OK to
exit. If, after changing the number, you decide to keep the original,
simply click on Cancel to exit.

Inserting a Page Break:

Max-10 allows you to start a new page on any line in the document
by inserting a page break. To insert a page break just select the
insertion point or anything to be replaced by a page break and choose
Insert Page Break from the Layout menu. A page break will then be
inserted at the insertion point. The page border appears as a dotted
line across the page. It can be selected by clicking in the empty space
created by inserting the break and deleted, moved or replaced.

File Edit Search+ Layout Font Style
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‘The Dictionary Option

Max—10 offers the convenience of an online spelichecker and a 50,000
word dictionary. This is available as a separate option. It is not
necessary to exit Max-10 in order to use the spelichecker. In addition,
you may even verify the spelling of a word before you type it into your
document. It is also possible to make your own dictionaries or to add
words to the -existing dictionary.

You may go on to the next chapter if you do not have the dictionary.

The UPGRADE utility

This utility will upgrade your Max—10 disk to use the dictionary and

spellchecker. It is easy to use and takes only a few minutes.

1) Make a backup copy of your dictionary disk. The beginning of this
manual explains how to backup disks.

2) Put the backup copy of the dictionary disk in drive 0 (zero) and type
RUN "UPGRADE". The disk light will come on and you will see a
screenful of text explaining what is happening. Press the ENTER
key when prompted.

3) Put a backup copy of your Max—10 disk in drive 0 and press
ENTER. The disk drive will run for about 10 seconds. After the light
goes out you may remove the disk. The Max—10 disk is now
upgraded and you may type RUN "MAX" as usual to use Max-10
and enjoy your new 50,000 word online dictionary.

Using the Spellchecker

There will probably be times when you will want to check your
document for correct spelling. The Max—10 spellchecker will check
your document for incorrectly spelled words by comparing it with a
large dictionary. Single letter words and any word that does not start
with a letter or which contains a number will be ignored. Hyphenated
words such as "Max-Ten" will be treated as two words, and
apostrophes are considered part of a word.

Searching for misspelled words: If the Check all Text command in
the Search+ menu is checked off, then the entire document will be
scanned. Otherwise, you may select a block of text to be checked for
correct spelling. If neither of these conditions is met then Max-10 will
begin at the current insertion point and continue to the end of the
document. To begin checking, put the dictionary disk in drive 0 and
click on Spelling Checker... in the Search+ menu if you have a 512k
CoCo. For a 128k CoCo, first put the Max—10 disk in drive 0 and then
click on Spelling Checker... A dialog box will pop up at the bottom of
the screen. Max—-10 owners who have 128k machines should now
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remove the Max—10 disk and put the dictionary disk in drive 0.

Now click on the Find button. A directory of files on the disk will be
displayed and you must choose the dictionary which you will use. The
dictionary supplied is called DICT/TXT. After the dictionary is loaded,
Max~-10 will then begin to process the text alphabetically. If an
unknown word is discovered, it will be displayed in the TextEdit box
and highlighted in the text window at the top of the screen. At this time
you have the option of correcting the word or clicking on one of the
following dialog buttons.

Find to continue checking the document.

Next to go to the next occurrence of the misspelled word.

Add to append the word to a list of new words which is stored in
memory. A 512k CoCo has enough memory to store about 2,000
words and a 128k will store about 75. The list may be saved to disk.
Shift-Add will perform an Add operation and then continue searching
(hold down SHIFT and click on Add).

Shift-Find will restart the search from the letter “a".

Shift-Next returns to the first occurrence of the word.

Pressing the BREAK key will hait a search in progress.

Correcting the misspelled word: To correct the word, you again
have a wide choice of options. You may type the correct spelling of
the word into the TextEdit box. Alternatively, click on Lookup to go
into the dictionary. Lookup will call up the dictionary dialog box which
allows you to scroll through the dictionary. While in this box you may
click on A or Z to go up or down about 1,000 words. Clicking on + or
- scrolis up or down about 100 words and the arrow keys move up or
down one word at a time. Hide will clear the dialog box and restore
the screen, returning you to the first dialog box. Clicking on any
dictionary entry will pull that word into the TextEdit box.

To replace the misspelled word with the word in the TextEdit box:

Click on the Fix button. If the word is capitalized, the capitalization is
matched by the following method: if the first letter of the oid word is
capitalized, the first letter of the replacement will be capitalized. If both
the first and the second letters are capitalized, the entire word will be
capitalized. Click on Fix All to replace all occurrences of the
misspelled word from the present position to the end of the document.
Shift-Fix will replace the word and then immediately continue
searching. Undo will undo the effect of the last Fix, Fix All or Next
button click. To exit the spellcheck box, click on Exit. Max—10 will ask
if you want to save the words you added to the dictionary. If you wish
to do so, click on OK and you will be prompted for the name to save
the list under. We recommend something such as TEMP - uppercase
letters may prove toc be more convenient when the list is added to the
dictionary. On a 128k machine, saving the list to disk will clear memory
of the new words list, 50 it might be a good idea not to save the list of
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new words until you are ready to exit Max—10.

Looking up a word In the dictionary: By pressing ENTER or clicking
on Lookup, Max-10 will search the dictionary for the word in the
TextEdit box. Remember that text may be brought into a TextEdit box if
you Cut or Copy it from a document and Paste it into the TextEdit box
using the ctrl-X, ctrl-C and ctrl-V commands. If the dictionary has not
already been opened, insert the dictionary disk in drive zero and click
on Lookup or press ENTER. When the directory of the disk is
displayed, click on the dictionary you will use (usually DICT/TXT). If the
word is found in the dictionary, it will be displayed in the dictionary
dialog box. If you Shift-click on Lookup, only the first few letters of the
text will be searched for.

Scrolling through the dictionary: At the right of the dictionary dialog
box is a set of control buttons. These are used to scan through the

dictionary.

To scroll Click on
Up one word Up arrow
Down one word Down arrow
Up 100 words - sign
Down 100 words + sign

Up 1,000 words A

Down 1,000 words Z

Click on Hide to replace the dictionary window with a document.

The Dictionary editor: The most common use of the editor will be to
add the new word files generated by the spelichecker to your main
dictionary. To do this, let us assume that, following the instructions
given previously, you have a list of new words saved as a file called
TEMP/TXT. You may need two disks: the original and a second to hold
the new, lengthened dictionary. it is best if the new disk is blank, as a
disk with files already on it can have a detrimental effect on the speed
of the spellchecker. Now, after you have exited Max-10, put the
dictionary disk in drive 0 and do the following:

1. Type RUN "DICTEDIT.

2. Select "2) Add New Words to Buffer" from the menu.

3. Enter the name of the file (TEMP in this case). If you are not using
drive zero, specify the full filename including the drive number: e.g.,
TEMP/TXT:1 means TEMP/TXT is in drive #1. You may load several
files if you wish. The buffer can hold about 2000 words.

4. Now select choice 4) Add words to dictionary and specify the old
dictionary name (usually DICT/TXT) and the new dictionary name. Give
the number of disks you will use. Remember that if the dictionary is
large, the new one may not fit on the same disk. If you are only using
one drive, you will be told when to switch disks. Be careful not to put
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the wrong disk in at any time.

When the editor is done, you will have a new. updated dictionary.
Other functions of the editor include:

Delete words: This removes unwanted words from the dictionary. To
do this, you will have to make a file of words you wish deleted from the
dictionary. Sglect #2 from the menu and lead in the file of words to be
deleted. Next, select option #5 Remove words from Dict Follow the
prompts as they appear and at the end of this operation, the words
specified in the kill file will have been removed from the dictionary.
Converting other dictlonaries: To convert dictionaries from other
word processors (Spelf 'n' Fix dictionaries work very well) take this
menu selection. The program will ask for the name of the old
dictionary - this is the dictionary you are converting; and the name of
the new dictionary - this is the one you will use under Max-10.
DICTEDIT will load in the old dictionary, compress it and filter out all
characters which the Spelichecker would ignore. The new dictionary
will be about 1/3 the size of the original list of words.

Making new dicticnaries: If you want to create your own dictionary, it
is not difficult. All you need to do is make up a list of words using
Max—10, one word per line and save it as an ASCIl file using the Save
ASCIL... command. Nexd, exit Max-10 and run the DICTEDIT program.
Select menu option #2 and load the file into the buffer. Now, choose
option #7) Convert iable o Dict. and give the name you want for the
dictionary. The list of words will be compressed and saved as a
Max—10 dictionary under the name you specified.
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Adding Pictures

fmporting Pictures into Max-10:

To add pictures to Max—10, you must first have used the picture
translator 1o convert the picture you want to use. To load this picture
into your document, click on the Paste File command.
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The Picture Translator:

The Picture Transiator is a menu-driven utility program included on
the Max—10 disk. it is used for translating pictures into a format that
Max-10 can understand. The translator will convert pictures which are
in the following formats: CoCo Max 1, 2 and 3, MGE, BASIC PMODE
4, HSCREEN 3 and HSCREEN 2. We will lead you through the
conversion of a CoCo Max and a CoCo Max Il picture, then discuss
the other options. Type RUN "PIXTRANS" to start the translator.

Loading a CoCo Max Picture

These pictures come in two types: CoCo Max (black and white) and
CoCo Max il {colored) pictures. A CoCo Max Picture is a PMODE 4
screen while a color CoCo Max Il picture is an HSCREEN 2 picture.
Converting a picture to a /CLP file that you can paste into your
document requires several steps. The picture must first be loaded,
which automatically converts it into the proper type to be saved. Then
it must be saved as a /CLP file. Each of these steps has several
options you can take. To load a black and white (PMODE 4) picture
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from CoCo Mayx, insert the disk containing the picture in the disk drive
and select the Load PMODE 4 {CoCo Max) entry from the menu by
typing in the number that appears to its left and pressing the ENTER
key. A list of all files of this type will appear. Again. enter the number of
the file you want. If you should want to stop and go back to the main
menu, press the BREAK key. The picture will now load. Only the top
of double—height screens will be loaded. Press any key after loading is
finished to get back to the text screen. A message will ask you if the
picture needs inverting {(most won't): just press ENTER to skip it.
Press ENTER at the offset menu, too.

A C6Co Max Hll picture can be loaded in much the same fashion.
However, since the original is probably in color, we must convert it to
black and white before we can use it. This is done by selecting a set of
halftones. Most of the time, we want the optput to be the same as if it
was printed in CoCo Max Ill, s0 we select the CoCo Max Il Printer
Dump option (The others will be discussed later). Now we must set
the picture size. You are given the "printed” dimensions of the picture
in inches and asked what type of sizing we want. In this case, we'll
use the One Magnification Factor option and specify a size of xt or
x2. x1 gives exact detail. but might look poor on some printers. x2 will
look good on ali printers and increases the width of the picture to
nearly fill the page. Now that the picture is loaded and converted, we
need to save it. The usual way to produce a small picture is to create a
CoCo Max page that is completely white except for the picture itself.
The translator will examine the picture, and find the size and location
of such a picture. Since, with some pictures, the top and bottom of the
frame used for sizing and moving it in Max—10 might be hidden, you
can add a top and bottom margin to the picture: however, this
increases the picture’s size in memory. Now you are given the amount
of space your picture will consume in Max-10. If the picture will be
larger than 7600 bytes, i will be split into several vertical sections. This
makes Picture Perfect give strange results. You also must drag each
piece separately to position the picture. Specify a file name, insert the
disk you want to add the file to and press ENTER. The transiator will
now save the /CLP file and return you to the main menu.

Translator Options: That takes care of straightforward picture
conversion, but the translator can do much more. We'll go through
each section, and describe each of the options to you.

Loading: You can load just about any type of PMODE 4 picture by
using the various file types in the PMODE 4 menu. If you can't find
your file's type, use the General option. A 5-level picture from a DS—-
69 digitizer can be loaded as a CoCo Max picture. Color pictures can
be loaded from /CM3 or /MGE files. You can also preload a picture, or
draw it from BASIC and then run the translator and use Convert
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HSCREEN 2. You can load /CLP files and re-save them, but the
original size data will be lost. Also, if the picture was 200 lines tail and
had margins added, the boltom may be cut off. HSCREEN 3 pictures
drawn from BASIC may also be loaded and converted, but if the
picture is a full screen is size, it can use up to 16000 bytes of your
buffer in Max-10.

Overlaying: Once a picture is ready o be converted, you'll be asked if
you want to add i to ancther picture. If you just press ENTER, the
buffer will be cleared and the picture placed at the left side of the
buffer. But you can also positicn the new piclure on top of, or beside,
a picture previously loaded. Options are given 1o put your second
picture beside a PMODE 4 or color picture. Or, you can directly anter &
position in pixels. The main idea in overaying is to create a wider
picture so you can get full detail on a printout. For example, you could
make a wide letterhead by drawing it in 2 halves, or add a picture
containing text beside another picture to label it. Note that this can be
very expensive in terms of memory used. By the way, full resolution
can be achieved on an 80 dpi printer by specifying x1 for
magnification, and specifying x0.67 for a a 120 dpi printer, then
re—stretching the picture vertically in Max-10. The maximum width
should be 560 pixels {7 inches) for an 80 dpi printout.

Halftonlng: Colcr pictures (CoCo Max I and HSCREEN 2) must be
converted to black and white for Max-10. But we can produce shades
of grey through halftoning. The only trouble with halitoning is that it
doesn't fare very well when the picture’s size is changed. So stick with
x1 or x2 in the sizing section if you use grey halftones. The translator
has several haiftoning options. You can select CoCo Max ilf printer
dump haiftones, Golor Max, or two types of ail black and white. You
can also dice right in and define which shade you want each of the 16
slots to come out as. Once that halftones are selected, the picture is
converted on the screen. i you like it, press ENTER at the "Halftones
OK ?" query. Otherwise, enter "N” and you get another chance. You
can also seiect Convert HSCREEN 2 from the main menu: the color
picture is still in memory and can be reused.

Picture Size: When you begin to save a picture as a /CLP file, the
translator scans the converted screen to find the picture itself. You are
then given the size that the picture would be on the printout if you did
not change its size. The picture size in Max-10 can be preset in the
transiator, as this allows finer control. There are two ways to set the
size: by magnification, or by final size. The final size method lets you
specify the dimensions you want to see on the final printout, but may
cause halftones or grey areas to have bars in them. The magnification
factor method allows you to make the final size an exact multiple of
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the original size, preserving halftones and keeping the picture perfectly
proportioned. Once the size is set. you can leave it in Max—10 or touch
it up. Note that if the final picture size you set is taller than a page, or
wider than the margins, it will be reduced to fit. Presetting the size is
the only good way to size a picture that is split into several parts.

Converting and Viewing: Since few people have “photographic”
memories, we've anticipated that you might want to look at a picture
before saving it, or resetting the halftones. There are several "View"
options in the main menu. The View /CLP option actually shows you
the converted picture, ready to be saved. A picture previously loaded,
or loaded before the translator was run, can also be converted using
the Convert entries on the main menu. These include HSCREEN 3
black and white pictures, which can't be loaded, but could be drawn in
BASIC. Finally, a menu option is supplied to change the disk drive that
pictures will be loaded from or saved to.

Changing the picture's position:

After a picture has been brought or "imported” into Max-10, it is
possible to move it about the document. If you just want to move a
picture down a few lines, you can place the insertion point just before
the top of the picture and press Enter a few times to push the picture
and any text below it downwards. Or, to move it up, position the
insertion point before the picture and press the left arrow key. To
move the picture around the document, it can be treated as any other
paragraph. Position the insertion point marker on the picture and click.
The picture will then become highlighted to show that it is selected.
You may now move it about using the Cut/Copy and Paste
commands as was explained in the "Working with Max-10" chapter.

To Resize a picture or shift it horizontally: First select the picture by
clicking anywhere on it. A black border with three *handles” on its
lower edge wili appear around the picture. Note that the top and
bottom lines may be partially missing or the lower handles may not be
visible if the picture did not have a white border. If you have trouble
seeing them, they are situated on the left and right edges and exact
middle of the bottom border. Next, drag any of the three handles to
resize the picture. If the picture becomes highlighted, you have missed
the handles and should try again, a little lower this time. The middle
handle lengthens or shortens the picture vertically and the left and
right handles are used to change the width and height of the picture.
The maximum picture height is six inches and maximum width is
seven inches. Picture width is also limited by the margins. The picture
is shifted horizontally by dragging either the left or right edge of the
frame. If a picture is larger than 7600 bytes, it will appear as several
smaller sections each of which must be moved or resized separately.
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Picture Perfect:

When you import a picture into a document it looks twice as high as it
is wide, compared to the printed version. This is due to the difference
between the CoCo 3's horizontal and vertical resoiutions. In order to
see how the picture will look when it is printed, use the Picture
Perfect command. Click on Picture Perfect in the Search+ menu. If
the picture was selected it will appear to have shortened vertically and
to have a "sizing frame" around it. This frame indicates the borders of
the picture on the printed page. You may now resize the picture in any
way you wish. if the picture you loaded was very large, Picture
Perfect will display it in sections separated by spaces. Do not be
alarmed: the picture will still be printed properly.
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Printing in Multiple Columns

Max-10 supports multiple column printouts, making it easy to produce
documents and newsletters with a very professional appearance. You
have the choice of no columns (normal printout), two or three
columns. Max~10 defines the first "page" as the first column, the
second "page” as the second column, and so on... The word "page" is
within quotation marks to indicate that we are referring to the areas
between the dotted lines which would normally be page breaks.
These "page breaks" indicate the beginning and end of columns.
To know what page you are actually on, refer to the page number
indication at the bottom left of the screen. Each column may be
formatted independently of the others. Note, however, that the number
of columns will be the same throughout the entire document.

To print in columnar format, we must first decide how wide the
columns must be. Let's say for example, that you wish to feed 1" left
and right margins and have two columns separated by a 2" space.
Remember that the page is 8V2" wide. By feeding 1" left and right
margins, we reduce its effective size to 612". Now, we want to
separate the columns by a space of half an inch, so that further
reduces the amount of text space on the page to 6", giving each
column three inches. Before we can set a column, however, it is
necessary to first ensure that the text is not too wide for the column,
so we go to the first ruler on the first page (this page will become the
first column) and drag the right margin marker to the 4" point (1"
margin + 3" column width= 4"). Repeat this for all rulers within the
document. As an aside: if you were using three columns, the second
column (on "page 2") would not need the extra space for the margin.
At this point, we can go into the Define Columns submenu in the
Layout menu and click on the 2 Columns button. Next, drag the
column marker across the ruler to the 42" mark (1" left margin + 3"
column + 12" space) this distance is called the column offset. By
doing this, we have caused Max—10 to recognize the first two pages of
the document as separate columns which will be printed on the same
page. To view the result before printing, click on Page Preview in the
Search+ menu and the page will be shown in its two column format.

Special Effects
In the event that you wish to have text or a picture cross a column
boundary (when creating a headline, for example), there is an easy

. way to do this. To create a banner headline, go to the top of the first

page and insert a ruler just beneath the one already there. Now insert
the text of the headline in between the two rulers and use the first ruler
to set the format of this headline. You should set the right margin of
this ruler to the width of the page. This will insert the headline in place.
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Next, to ensure that the other columns do not overwrite this headline,
go to the top of the second (and third, if there is one) column(s) and
insert white space by pressing ENTER. This will force the other
columns down, out of the way. This works because Max~10 interprets
white space as being transparent when assembling columns, so the
headline “shows through" this transparent space in the other columns.
Another way of making a headline is by use of the Edit Header or the
Edit Footer command. Headers and footers will always cross column
boundaries if their margins are set wide enough. The idea of
"transparent space” may also be used to have a picture which goes
across a column boundary. Imagine for example that you want to put
a picture at the bottom of the second and third columns. Simply use
Paste File to put the picture at the bottom of the second column and
stretch it across so it overlays the area where the third column would
go (if you ever lose track of what you are doing. just click on Page
Preview to see how your page will appear). Then continue to enter
the text of the third column as usual. When you have reached the top
of the picture (remember Page Preview), insert a page break to fill the
rest of the column with white space.

Max—-10 also permits the overlaying of several pages. To do this, just
move the column offset marker to the 0 position and click on the
button which indicates the number of pages you want overlayed.

Placing pictures next to text

Transparent space is also the means by which we can place pictures
next to lines of text.

To put text and pictures next to each other, we first enter the text,
leaving whitespace where the picture should fall and then move the
picture into the correct position.

For example, you want to send a letter with a picture embedded in the
middie of the text. The picture is three inches wide. For the first third of
the letter, just type the text in normally. Then when you come to the
section where you want to put the picture, insert a ruler and remove all
but one tab. Let's put this tab at the 5 inch mark. Now continue typing
as before, but whenever you reach the 2 inch mark on the ruler, press
the tab key, leaving a 3—inch space. Continue deing this for as many
lines as the picture will occupy. After reaching the end of the region
which the picture will occupy, copy the first ruler to this point and
finish typing. At the end of this you will have a page of text with a
blank area in the center. Now piace the insertion point at the top of the
next page and copy the second ruler {the one with the 5-inch tab)
here. Press ENTER to insert the same number of blank lines as there
are lines of text before the space on the previous page. You can now
load in the picture and resize it to fit in the space which was left in the
text. Now go to the Layout menu and click on Define Columns...
Select two columns with an overlay of zero. Now, when you click on
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Creating new font sets.

A maximum of 14k of memory is allocated for fonts. Because of their
different sizes, the number of fonts which can be used at one time will
vary. Fonts in smaller point sizes take up less room than the larger
point sizes. Thus it may be possible to put eight or nine fonts in a
single font set. There are two versions of each font: 80 dots per inch
(dpi) for the screen display and low resolution printers and 120 dpi for
higher resolution printers. These are high—density fonts which were
created for Max—10 and they are not compatible with CoCo Max fonts.
If you want to create your own fonts, the Max—10 technical manual ($5
+ $4 S&H) has information on the format used in font storage.

1. Place your font disk in drive 0 and type RUN "FONTS". A list of the
18 fonts on disk #1 will appear.
Press <CLEAR> to switch to the list for disk #2. You can make up
font sets with fonts from both disks.

2. To the left of each font is a letter. By pressing this letter, you select
or deselect the font. if the font is selected, a “Y" will appear to the
right of the font name; if the font is not selected, an "N" will be
displayed. If there is a dash (-) to the right of a font, this indicates
that there is not enough memory left to load this font. It is best to
start by loading the larger fonts first.

3. When you have selected all the fonts you want, press <ENTER>.
You will still have an opportunity to go back and change your
selections by pressing <BREAK>,

4. Next, the fonts must be placed in the correct order. This may be
important because Max—10 assigns fonts according to their order in
the Font menu. This means that if you have a document which is
written in Script (the first font on the Max—10 font menu) and you
create a new set which has Brookhaven as the first font and Script
as the second, when this document is loaded, it will be displayed in
the Brookhaven font. This is because Brookhaven has taken the
place that Script previously occupied.

To sort the fonts, just enter the letter code of the font which is to be
moved, and then enter the letter of the position to which it must be
moved. Press <ENTER> when you have finished.

5. Press '2'. This tells the font assembler that you have the new
version of Max—10. After this, set will be saved to disk and you will
be prompted to change disks as is necessary. When the font set
has been saved, the fonts are ready for use.

When you are in Max—10, put the font disk in drive 0 and click on the

Font Set... command to load the fonts.
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The Document

Information about your Document:

The About... dialog box in the Search+ menu displays the following

information:

» Amount of memory used (in bytes)

> Amount of memory still available

» Size of the file in disk granules

» Number of pages

» Number of paragraphs (remember, page breaks, rulers and pictures
are considered paragraphs)

» Number of words (in large documents, this may take 1-2 seconds
to appear) -

> A pictorial representation of memory use in the document is also
displayed. When the black area touches the grey at the top, you
have less than 8k of memory left. Some operations are not possible
when the memory marker reaches this grey area.

Opening an existing Document:

To load a document which was already created into the computer,
there are two commands available. Load... is used to load a file which
was created by Max-10. Load ASCIL... will load in any file saved in
ASCII format. This includes most word processor files and BASIC
programs saved in ASCIl format (the disk drive manual explains how
to do this).

To load a file: Choose Load... (or Load ASCI\...) from the File menu.

Max—10 will show a directory of the disk and prompt for a file to load.
Click on the file you want to load or click Cancel to exit. if you click on
a file and it is a valid ASCIll or Max~-10 file, a copy of that file will
appear on your screen and you may begin to edit or add to it. The
original is still stored on the disk.

Max~10 will interpret characters from an ASCI| file in the following
manner:

— ASCII 9 is interpreted as a tab

- ASCIl 13 is a linefeed

— ASCIt 32-127 are normal printable characters

— Everything else is replaced by ASCII 127 (] ) —a graphic block

Saving the Document:

Your text should be saved to disk fairly often (every 15-30 minutes) in
case there is a power supply problem or any kind of system
malfunction with the computer. Some menu options as well as your
position in the document are also saved.
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To save text: Choose Save... from the File menu. You will be
prompted for a document name. If this is the first time you are saving
the document or you want to change the name to save it under, type a
name in the box. Otherwise, if a name is already highlighted in the box
and you wish to save under this name, just click on the Save button. If
you enter the name of an already existing document, Max—10 will ask
you if you want to overwrite the existing document with this one. Click
on OK to overwrite the document or on Cancel to abort saving.

If you want to save the document in ASCII format, Choose Save
ASCIL... instead. The procedure will be the same as the normal save.

In the event that you get a message indicating that the disk is too full
to save your document, you have two choices: You may either replace
the disk with another formatted disk which has enough room for the
document, or you may click on OK to exit the Save dialog box then
choose Kill A File from the File menu.

To delete a file from the disk: Choose Kill A File from the File menu.
A list of files on the disk will appear on the screen. Click on the file you
want to delete and if you are sure that you really want to delete that
file, click on OK in the dialog box that pops up and that file will be
removed. If you selected the wrong document, just click on Cancel
and you will not accidentally delete that document.

Page Preview:

Before you print the document, you may wish to see how each page
would look when printed out. This is the function of the Page Preview
command. Click on Page Preview in the Search+ menu and after
about one second, a picture of a full 10x8v2 page of the document
appears on the screen. This is a reduced version of the current page.
To examine the entire document, use the scroll bar. It works as usual,
but will scroll by pages instead of by lines. When you are ready to exit,
simply click on the display of the page.

Printing your Creation:

When you are ready to print the document, click on Print... in the File

menu. A dialog box will appear showing the various printing options.

Click in the button next to your choice to select the desired print

mode.

- Full Graphic Output: This is the usual mode for printing the final
draft of a document. It provides for printing pictures and text with
multiple fonts and styles.

- Double Strike Quality: Double Strike is similar to Full Graphic
Output but the print quality is darker and text and pictures are better
defined. The drawback to using this mode is that because the printer
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must make multiple passes over each line, printing takes longer than
with Full Graphic Output.

- Draft Mode: Text Only: This will produce a fast, text—only draft of
your document for proof-reading purposes. Pictures and the special
Max—10 text features (such as fonts and styles) are not shown in
this mode.

- Double Spaced Draft: This is the same as the standard draft mode,
but text is double spaced.

Printing normally starts from page one. To begin printing from any
other page, just type in the page number and you will see it displayed
in the First Page: box. Max—-10 will usualiy just print an entire
document continuously. If you wish to use single sheets of paper, click
on the Single Sheets/Pause button and Max-10 will stop after
printing each page so that you may reload the printer. Note that with
single sheets no top margin is ejected, so if you want a margin, you
must roll the paper the desired amount past the print head before
printing. With fanfold paper in graphic mode, start with the paper even
with the top of the print head because one inch margins are ejected at
the top and bottom of each page. In draft mode this margin decreases
to one—half inch.

When you have selected the options you want, click on the OK button
to start printing. If at any time you want to cancel the print, just press
the BREAK key. If you need to pause momentarily, hold down the
spacebar to stop and press it again to continue. As the document is
printed, the scroll box will move down the bar and the page number
will change to indicate the part of the document which is currently
being printed.

Because margins are not ejected in the single sheets mode, you may
“trick" the computer intc printing on the entire length of a sheet of
paper by rolling the platen so that the top of the page is even with the
print head and then clicking on Single Sheets/Pause. When Max-10
gets to the bottom of a page in memory, it will pause and prompt you
to insert another sheet of paper and press the spacebar. Just press
the spacebar at this point (if you are actually using single sheets, be
ready to pause the print when the end of the sheet is reached).
Printing will then continue from the present line. No bottomn margin will
be ejected and the entire page will be filled with text. Note that this is
not the expected use of the Single Sheets/Pause command. You
should therefore exercise caution when using the command for this
purpose because of the following reasons: 1) Text may be printed
across the seam of two sheets of paper. 2) Headers and footers (and
consequently, page numbers) will not print in their proper positions. 3)
If you are using single sheets of paper, the printer may not stop even
after the end of the sheet is reached.
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Printing a Long Document:

Max-10 is capable of handling documents of up to 88 pages in length.
The actual number of pages which will fit into memory depends on the
font, text styles and the number of pictures in the document. If you
wish to make longer documents, you may break a long piece of text
into several smaller documents saved under different names.

To do this, first load the first document to be printed. Next, set the
page number you want the first page of the document to have (See
Changing the First Page Number above). Finally, print the document
as was explained in the immediately preceding section and continue
this procedure for all documents making up the entire text work.
Remember to make the first page number of each document one
more than the last page of the previous document.

A few notes on printing

Max—10 does not allow inserting printer codes within the document.
The draft mode is intended for high—-speed printout for proofreading
only. There is no formatting in draft mode.

Exiting Max-10:

When you are sure you have finished, click on the Quit option in the
File menu and a dialog box will pop up to make sure you want to quit.
If you decide against exiting. (perhaps you forgot to save the file), just
click on Cancel and you will stay in the document. Otherwise, click on
OK and Max~10 will return you to BASIC.
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REFERENCE GUIDE

This chapter is an overview of Max—10. It presents the basic concepts
of using the word processor, describes the commands and ends with
technical information and a glossary.

The Document
The document consists of paragraphs, headers, footers and rulers.

A paragraph is defined as either:

— A Ruler

— A picture

— A page break

- A body of text enclosed between the limits (beginning and end) of
the document or presses of the ENTER key

In a paragraph, the format (margins, line spacing and indentation, and
tab sets) is defined by the settings on the ruler. The position of the first
character is determined by the indentation marker. When your typing
reaches the right margin, the words are automatically wrapped around
to the next line and any subsequent editing of the paragraph will result
in the paragraphs being reformatted to fit the ruler settings.

A page is defined as the area between page breaks or between a
page break and the beginning or ending of a document. A page
break is shown as a gray dotted line that goes across the screen. Of
course, this line will not be printed.

Editing is the act of changing the document by replacing, inserting,
deleting, moving or copying selected text. Any contiguous group of
items can be selected by Max-10. The insertion point can be placed
anywhere in the document. You are even able to move selected text
between different documents. The Undc command will restore the
previous state of the document.

Rulers are used to set all paragraph formats. Margin, paragraph
indentation, line spacing, justification and tabbing are all set by the
ruler. The format set by a ruler affects all subsequent text until the
next ruler.

Margins are used to set the maximum iine length. Left and right
margins may not be set within V4 inch of a tab stop or within 2 inches
of each other.

Indents are set by the indentation marker. The indentation marker can

Max-10 Page 55 (e



be placed on top of the left margin marker for no paragraph
indentation, to its right for regular indentation, or to its left for hanging
indentation. When a paragraph has hanging indentation, the left
margin acts as a tab marker.

Tabs align tabbed text with the tab marker. A maximum of eight tabs
may be set. When all tabs are used, the triangle in the tab well
disappears to indicate that there are no more tabs. Pressing the tab
key (right arrow) moves the insertion point to the next tab marker. If
there are no more markers on that line, the insertion point goes to the
first marker on the next line. Removing tabular text will not remove the
tab itself. To remove the tab, you must select the entire space
preceding the text (this is the tab itself) and cut or backspace over it.
Tabs give best results when used with left aligned or fully justified text.
If no tabs are set, pressing the Tab key (right arrow) inserts "hard"
spaces which will not be changed when Max-10 reformats the text.

Alignment determines whether text will be aligned with the left or right
margins, both margins, or centered on the page. Tabs may affect the
alignment set in the alignment box.

The Line Spacing boxes set the spacing of lines in the document.
Single. double and one and one-half line spacing may be set: just like
with most typewriters.

Headers & Footers define the top and bottom margins of pages. They
may contain page numbers, titles and even pictures. A document may
have a header, a footer or both. To create a top or bottom margin
height greater than one inch, add biank lines to the margin by hitting
the ENTER key. Blank lines may also be used to force the header or
footer away from the rest of the text on a page. Anything that can be
cut or copied to the clipboard can be pasted to a header or footer. The
maximum height of the header/footer is one screenful and the
header/footer may contain no more than nine lines or five paragraphs
including the ruler. You will be warned if you exceed the maximum
number of paragraphs or lines when you attempt to exit the header or
footer editor.
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The Menus

The Menu Bar is the line across the top of the screen where the
menus are selected. Within these menus, when a selection is made it
is highlighted and when you click on that selection, a check mark
appears next to it.

The File menu

New: This command is used to start a new document.

Load... This is used to load a file created by Max-10.

Load ASCIL... This is similar to the Load command but is used to load
a file not created by Max-10.

Save... This command saves documents to disk. Max—10 first checks
to ensure that there is room on the disk and if it finds a file which
already has the name that you are trying to save your document
under, it will ask whether you want to overwrite that file or not.

Save ASCIL... This differs from the Save... command in that it does
not save in Max—10 format. Tabs are saved as ASCII 9 and line feeds
are saved as ASCIl 13 characters so that the documents may be used
by any other word processor requiring ASCII files.

Directory: Gives a listing of all files on the disk and amount of free
space.

Kill File: This command gives you the option of deleting files from the
disk.

File Drive...: This is used to assign one of a maximum of four disk
drives to be used for document storage. Click on the Verify Data box
and whenever a file is saved, Max—10 will verify that it was saved
correctly.

Font Set... Extra font sets may be loaded from drive 0 using this
command.

Print... Prints the document currently in memory.

Quit Exits Max-10 and returns to BASIC.
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The Edit menu

Undo Last: This command will reverse the effects of your last action.
It is like always having a copy of the previous form of the document.
Note that for this and several other menu commands, on the right of
the menu is a small "c" and a capital letter. If the CTRL (control) key is
held down and that capital letter is pressed, the corresponding
command will be executed. This is a quick way of using some
commands without having to take your typing hands off the keyboard
to use the mouse. Note that these keys are adjacent to each other
and chosen for their proximity to the control key to allow one-hand
operation.

Cut: This command is used to move a section of your document after
it has been selected with the mouse. Cutting puts the area selected on
the Clipboard and removes it from the document.

Copy: This is similar to Cut, above, but instead of removing the
selected from the document, it just saves it on the Clipboard so it can
be pasted elsewhere.

Whenever text is cut or copied, the spaces around it are preserved so
the user does not have to reinsert spaces when it is pasted.

Paste: This command places the current contents of the Clipboard
into the document at the insertion point or replaces selected text. The
insertion point then moves to the end of the inserted material.

Show Clipboard: This command allows you to view the contents of
the Clipboard without actually pasting it into the document.

Save RamClip: This command is used to save the RAM clipboard to
disk.

RAM Clipboard: Indicates whether Clipboard is stored in memory or
on disk. When checked off, Clipboard is in memory.

Clipboard Drive: Makes it possible to change the disk used for
Clipboard loading/saving.

Paste File: This is used to paste any file into the document at the
insertion point.

Show File: This command allows you to view part of a Max—10
clipboard file stored on disk. When Show File is chosen, a directory
will appear and you may choose the file to be viewed. The top part of
the selected file will appear onscreen. This command is intended to be
used in the event that you have many documents on disk and you just
need a quick idea of what they look like.
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The Search+ menu

Find/Change: Clicking on Find/Change brings up a dialog box with
Text Edit boxes for the target string to search for and the string to
change the target to. After you type text in the "Change to:" box, Max—
10 searches the document for the text specified in the "Find:" box and,
optionally, changes it to the text in the "Change to:" box. Only the
most recent change can be undone. Clicking on Change All will do
this throughout the entire document. If, when you enter the
Find/Change dialog box, there is already text in the "Find:" box,
clicking on Find or hitting OK will cause Max-10 to search for this text
again. Clicking on the Cancel button will exit. If an area of text is
selected, then Max-10 will skip over this selected area when
executing its search. The next four commands may also be accessed
by the control codes on the right of the menu.

Find Next: This command continues the search begun in
Find/Change.

Change: Change the text just found to the string in the Change box.
Change/Next: Change text found and search for next occurrence of
target string.

Go to Page #... This allows you to quickly find a specific page. On
clicking on OK or hitting ENTER, Max-10 goes to the top of the page
whose number appears in the box. If you specify a number which is
below the first page number, Max—10 will go as far as the top of the
first page, if you give a number beyond the last page, it will go to the
top of the last page in the document.

Key Click: Toggles the sound of clicking keys on and off through the
speaker. Turning this off speeds up typeahead.

Picture Perfect: This command gives true proportional pictures.
Usually, pictures onscreen look twice as high as they are wide,
compared to the printed version. Picture Perfect shows you the
picture in the correct proportions so it can be easily adjusted for best
aspect ratio. ’

About... Clicking on this command will bring up a dialog box which
provides information on the state of the document.

Page Preview: This command displays pages of the document, one
at a time, as they would appear if printed on 11x812" paper.

Spelling Checker..: Calls the Spelichecker — a separate option.
Check all Text: Sets whether or not the entire document is to be
checked for correct spelling (separately priced option).
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The Layout menu

insert Ruler: This command places a ruler at the insertion point and
moves the insertion point below that ruler.

Show Rulers: This command allows you to make the rulers visible or
invisible within the text. When checked off in the menu, rulers are
visible; otherwise they are hidden to show the text as it will be printed.
Edit Header: This command is used to create or edit headers. All the
normal text editing functions and commands are available when in this
mode.

Edit Footer: Identical to Edit Header except this is used for footers.
Show Header/Footer: This command works like the Show Rulers
command. When there is a check mark next to this menu choice,
headers and footers are visible, otherwise they are hidden but they still
take up “hidden space” on the page, reducing its length.

Set Page Number: Allows you to set the number of the first page in
the document. This is useful when printing a long report when it is
broken up into several documents. The first page of each document
can be assigned a number one greater than the last page of the
previous document so all the pages will be numbered as if they were
from one large document.

Insert Page Break: This command breaks the page at the insertion
point, filling the rest of the page with empty space and places any
following text onto the next page. The page break area may be
selected by clicking in it.

Define Columns...With this command, the user may prepare the
document to be printed in a muiti-column format.

The Font menu

Max—10 starts out with the Font set to the first font in the menu. The
number on the right of the font name is the point size, or the number
of lines used in drawing the font. You have the option of choosing any
of the fonts for text which is about to be typed or which is currently
selected. Note that the number of lines which will fit on a page is
dependent on the font selected.
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The Style menu

Max-10 allows you the option of changing text style anywhere in your
document. Styles may be intermixed to provide the desired effect. The
preset style is Plain Text. Style is changed by selecting text and
clicking on the desired style. If text is not currently selected, then text
will assume the new style as it is typed at the insertion point. It is
possible to choose more than one style at any time as long as they do
not conflict, that is: it is impossible to select Plain Text and [talics at
the same time as plain text is by definition not italicized. Text style can
also be changed by using the control key definitions shown on the
right of the menu.

At the bottom of this menu is the entry:. as Space. When checked
off, the ALT-SPACEBAR combination inserts an unbreakable space in
the document. When it is not checked off, a black square appears
when ALT-SPACEBAR is pressed. This square is the garbage
character with which Max-10 replaces unrecognized ASCII characters
from documents created with other word processors.
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Memory and Error Messages

Max—-10 is a highly complex software product with its own unusual
quirks. On some Color Computers the message, "Memory is nearly
full. Last chance to Undo" might be displayed soon after you start
Max—-10: even with a very small document. Just ignore it and click on
OK.

There are times when your document may be so large that it becomes
a dangerous condition. '
Memory too full to Undo: Max-10 tries to always keep a copy of the
current paragraph in memory in case you want to undo something. If
the document gets too large, in order to allow you to continue
working, Max—10 must give up this extra storage space. When this
message is displayed, you are being warned that after the present
operation, changes previously made may not be undone and you are
being given a final opportunity to Undo what has been done so far.

Memory too full to perform operation: This arises when Max-10 is

asked to do an operation which requires more memory than is

currently available. The operation wiil be aborted and a dialog box will
inform you of this.

Operation creates too many paragraphs or paragraph is too long:

As this suggests, you have requested an operation which would resuit

in more than 6,000 characters in a single paragraph or more than 480

paragraphs in a single document. One of two dialog boxes will appear

to tell you which of these conditions has occurred. If a paragraph will
be too long, it should be broken up into two halves by pressing

ENTER midway through the paragraph. Conversely, by removing line

feeds, a document with too many paragraphs may be brought within

the acceptable limit.

Document is too long to show bottom: This is a very rare condition

which can arise due to an unusual format such as very large fonts and

narrow margins with double spacing set. If this message appears, one
of these two solutions will resolve the problem:

- If you have just changed the line spacing, font size or ruler format,
try using the Undo command to reverse what you just did. If this
doesn't work:

- The document should be reduced in size. To do this, select the first
half of the document and Cut it to the clipboard. (Note: if you have
Ram Clipboard turned off or you are using a 128k computer, either
save the clipboard to a different disk or immediately after cutting the
first section of the document to the clipboard, save the rest of the
document. Now load the clipboard (using Load...) and then you may
continue working. The reason for this is: after performing the Cut
operation, the first half of the document will be saved as
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CLIPBORD/CLP. If you now attempt to Cut or Copy something eise,
the computer will save it to disk as CLIPBORD/CLP, erasing the haif
of the document saved under that same name.) If you are using a
512k computer, save the text using the Save RamClip command.
You may now continue to enter text in the second half of the
document which remains in memory. The first half will still be on disk
when you are ready to print or to edit it again.

About Printers

Max-10 is supplied with a variety of printer drivers to work with the

more popular printers on the market today. Printers are selected using

the CONFIG program. If your printer is not on the list in the CONFIG
menu, you will have to do a bit of experimenting. Configure Max-10
and choose a printer that seems compatible with yours. Then run

Max-10 and do as follows:

— Make sure you reset your printer (turn it off for a few seconds) and
that the baud rates are set correctly.

- Press the BREAK key-to stop the printing if it's erratic.

You can reconfigure your Max-10 disk as many times as you need, so

you may try it with the different printer drivers, to test them.

Do not use the 9600 baud setting first. Select 600 or 1200 baud. When

everything works fine, you can then try higher baud rates. Make sure

you reset the printer (turn it off for a few seconds) between each
attempt. With serial printers, check the DIP switch setting in your
printer for the correct baud rate.

Additionally, check the following:

— Many printers have an IBM or Epson compatible mode. If your
printer does, put it in this mode (refer to your printer manual) and
select the IBM/Epson driver in the CONFIG printer menu.

- Select the standard pica width (10 cpi), if your printer offers a
choice.

~ Select Carriage return with linefeed.

Verify that the baud rate set on your printer or on the serial to parallel

interface (if using a parallel input printer) are set to the same rate that

you just selected with the CONFIG program. Some serial to parallel
interfaces require that you press a reset button on the interface.
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Max—10 Technical Information

Default (Preset) Options:

ASCH files may have any extension except CLx ("x" may be any
character allowed by the DOS). The extension defaults to /DAT but if a
document is loaded or saved in ASCI| format with a different
extension, the default will be changed to this extension.

Clipboard and document files always have a Clx extension.

128k computers:

Buffer size: 32k

Document limit: Approx. 44 pages

Clipboard storage: Switchable between 200 byte RAM or disk
- filename is always CLIPBORD/CLP

- drive is set with CONFIG

512k computers:

Buffer size: 64k

Document limit: Approx. 88 pages

Clipboard storage: Switchable between 100k RAM or disk

ASCII Files

When Max—10 loads or saves ASCII files, text characters (ASCli 32—
127) are loaded as their standard ASCIl codes, line feeds are
interpreted as 13 (decimal) and tabs as 9 (decimal). All other
formatting characters are replaced with decimal 127 (] ) characters.
If you wish to remove these characters, copy one into the
Find/Change dialog box and use Change All to delete them from the
document.

The printed page:

Printer: 80 or 120 dots per inch
Minimum margins (11 x 8.5 inch paper):
- Top: 1"

- Bottom: 1"

- Left: 5/8"

- Right: 3/4"

About Printers:

Max—10 is supplied with drivers for the following printers:

DMP105R, DMP130R, DMP106 (IBM mode), CGP220, Gemini,
OKlIData 92 and IBM/Epson compatibles. The Okimate 20 may be
used with the DMP106 IBM mode driver.
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Glossary

ALT: A key used in conjunction with other keys to perform operations or print
characters not included on the keyboard.

ASCII: An acronym formed from the words American Standard Code for Information
Interchange. ASCII is the most commonly used format for storing text files on disk.
Backspace: The left arrow key which moves the insertion point backward removing
selected text or characters before the insertion point.

Button: Buttons are little circles, squares or ovals inside dialog boxes that are clicked
to perform an operation.

Caps lock: This causes all letters to be typed in uppercase. On the CoCo it is
activated or deactivated by holding down the Shift key and hitting O (zero).

Check box: A box within a dialog box which is used to set or reset a parameter used
by the dialog box's host command.

Choose: to pick from a menu by clicking the mouse button.

Click: To position the pointer and then briefly depress the mouse button and release it.
Clipboard: This is the area where selected text is held when Cut or Copied.

CoCo: Abbreviation for Color Computer.

CoCo Max 3: A graphic painting program which was the predecessor to Max-10. Its
pictures may be translated and loaded into Max-10 documents

Command: A word that tells Max-10 to carry out an operation.

Control (CTRL) key: The key used in conjunction with some letters as a short form of
certain commands.

Cut: To remove selected text from its present position.

Dialog box: A box that Max-10 uses to give or request more information.

Document: A Max—10 document is composed of text, format information and pictures.
Drag: The action of moving the mouse with the button depressed. It is usually a
sequence of moves consisting of placing the pointer on something, holding down the
button and moving the mouse to another spot and then releasing the button.

ENTER: The key used to end a paragraph or enter a blank line.

Font: A specific style in which letters, numbers and punctuation are drawn.

Format: The format is the layout of the text in terms of margins, line spacing, tabs and
justification. i

Granules: A measure of space on the disk. A granule is equal to nine sectors. See
your disk manual for more information.

Hard Space: A space which will not be removed when Max-10 justifies a line of text.
Header: The header is the top margin of a page. It may contain text, pictures and page
numbers.

Highlight: Highlighted text is displayed with the colors reversed.

icon: Graphic representation of an object. Max-10 icons are the clock in the fower
right, the tab wells, alignment and spacing markers and the arrows at either end of the
scroll bar.

Indentation marker: The indentation marker is the arrow on a ruler line that marks the
point at which paragraphs will be indented. It can be dragged to a new position.
Insertion point: This is the point at which something will be added. It is marked by a
blinking vertical line.

Margin marker: A biack triangle on either side of the ruler which indicates the present
positions of the margins. It can be dragged to a new position.

Menu: The list of commands that pops up when you choose one of the six titles at the
top of the screen.

Menu bar: The list of menus that is shown at the top of the screen.

Paste: To put back into the text something that was Cut or Copied.

PIXTRANS: The program included with Max—10 which reformats pictures in order that
they may be loaded into documents.
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Pointer: A small arrow or vertical 1-bar that indicates the position of the mouse.

Press: To position the pointer over something and then hold down the mouse button
without moving the mouse.

Auler: The horizontal bar which holds information on screen format.

Save: To store information on a disk.

Scroll: To move the window vertically over the document to view a different pan of it.
Scroll arrow: The arrows on either end of the scroll bar used to scroll up or down one
line.

Scroll bar: The vertical bar on the right of the screen.

Select: To highlight an area on which an operation is to be performed.

Shift-click: An operation used to select a large area. Move the pointer and then select
the area between the pointer and the insertion point by holding down the Shift key
while clicking the mouse button.

Shift keys: The keys on the bottom row of the keyboard which cause uppercase
letters or the upper characters on some keys to be printed.

Style: A different way of presenting letters, numbers and punctuation by undertining,
boldfacing or otherwise changing the appearance of the character while retaining its
basic shape.

Tab: The space between the place where you press the tab key and the position of the
tab marker.

Tab key: Tabs are inserted by pressing the right arrow key.

Tab marker: An outlined triangle which indicates the position where a tab is set.

Tab well: The icon where tabs are kept until needed.

window: The area of the screen where your document appears.

Word wrap: The Max-10 feature that pushes words onto the next line as you approach
the right margin without breakingthem.
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The Control Keys
Hitting any of these keys while holding down the <CTRL> key will
perform the equivalent menu command or select the font. |

Command Letter Style Letter |
Undo/Redo Last z Plain Text P |
Cut X Bold B |
Copy C Underlined U

Paste \ Superscript H

Find Next F Subscript L

Change R ltalics I
Change/Next N

Go to Page # G

The ALT keys

Hitting any of these keys while holding down the <ALT> key will
display the indicated character.

Key Character
A ©

B _

c 0

D {

E }

<SPACEBAR> B
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About Printers 64

About... 51, 59
Alignment 12, 56
ALT keys 6, 67
ALT-SPACEBAR 61
ASCI Files 51,64
Backspace 6, 20,27
BACKUP 3
Bold 15
Break 23
Buffer size 64
Capitalization 30
Case significant

searches 30
Center—alignment 12
Change All 31
Change/Next 59

Changing Alignment 12
Changing Line

spacing 11
Changing Text Style 15
Changing the Style or

Font 33
Checking Your

Spelling 37
Clipboard 18
Control Keys 67
CLEAR 20.27
Click 12,24
Clipboard 19, 64
Clock icon 5
Column 34
Column offset 46
Columns 46
CONFIG 4
Control 6
Copying 19,29, 58
Copyright 3
Correcting a

misspelling 38
CTRL-F 31
CTRL-R 31
Cut 18, 19.27.58
Define Columns 46, 60
Deleting afile 52
Dictionary 37
Dictionary editor 39
Directory 57
Document 9. 51,55
Document is too long 62
Double-click 15,24
Drag 11,24
Edit Footer 60
Edit Header 60
Edit menu 58
I diting 14, 25,55
I NIER 9
) ttor Mossaggens 62

Moo (0

Exiting Max-10

Extension

File Drive

Find/Change

Font menu

Font set

Footnotes

Format 10,

Full

Full-justification

Glossary

Go to Page #...

Graphic

Headers & Footers

Headers and footers

Hiding Rulers

Highlighted

Icon

Importing Pictures

Indentation 10.32,

Insert Page Break

Insert Ruler 21,

Inserting

Inserting a Column in a
Table

Justified

Key Click 6,

Kill File

Layout menu

Linefeeds

Line Spacing

Load

Load ASCII...

Loading a file

Margins

Matching words only

Memory

Memory too full for
operation

Memory too full to
Undo

Menu Bar

Move

Moving a picture

Moving and Copying

Moving Text

New 16,

Next

Opening Existing
Documents

Operation creates too
many paragraphs

Page

Page Preview 52,

Page break

Picture Perfect

Pictures

Point

6,9,

Page 68

Press 12,24
Print 57
Printed page 64
Printing 23, 62
Printing in Columns 46
Quit 57
RAM 19
Ram Clipboard 18, 58
Redo Last 9
Reference guide 55
Removing 17.27
Removing Selected

Text 20
Replacing a Selection 16
Resizing a Picture 44
Rulers 10,22
RUN "MAX" 4
Save 57
Save ASCIL... 57
Save RamClip 19, 58
Saving the

Document 23.51
Scrolling 12,18,21.24
Search+ menu 59
Searching 29,30
Selecting 15,25, 26
Set Page Number 60
SHIFT-0 6
Shift-Click 20. 24
Show Clipboard

18,19, 58

Show File 58
Show Header/Footer 60
Show Rulers 22,60
Spacebar 23
Spacing 11
Special Effects 46
Starting another

Document 16
Style menu 61
Subscripting 33
Superscripting 33
Tab 6,13, 25, 32, 56
Table 34
Text sizes 33
Translator 41
Undo 9
Undo Last 58
Up 12
Using Tabs 13
Using the Mouse 24
Using the

Scroll Bar 12,24
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